diff mbox series

[bug#54457,3/9] gnu: Add libnetfilter-cthelper

Message ID 7fab503e-2634-b878-d844-e322a56893b1@gmail.com
State Accepted
Headers show
Series Add netfilter tools and libraries | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

fesoj000 March 19, 2022, 12:47 a.m. UTC
* gnu/packages/linux.scm (libnetfilter-cthelper): New variable.
---
  gnu/packages/linux.scm | 25 +++++++++++++++++++++++++
  1 file changed, 25 insertions(+)

Comments

M March 19, 2022, 11:26 p.m. UTC | #1
fesoj000 schreef op za 19-03-2022 om 01:47 [+0100]:
> +   (description "libnetfilter_cthelper is the userspace library that provides
> +the programming interface to the user-space helper infrastructure available
> +since Linux kernel 3.6.

I think that nowadays >3.6 can be assumed, especially since the Guix
daemon uses the namespacing features which requires a recentish kernel,
so this doesn't need to be mentioned I think?
M March 19, 2022, 11:27 p.m. UTC | #2
fesoj000 schreef op za 19-03-2022 om 01:47 [+0100]:
> +   (synopsis "Library for kernel user-space helper infrastructure.")

What kernel user-space infrastructure, precisely?  Taken to the
extreme, can I use this library to turn off a CPU?

Greetings,
Maxime.
M March 19, 2022, 11:28 p.m. UTC | #3
fesoj000 schreef op za 19-03-2022 om 01:47 [+0100]:
> +   (description "libnetfilter_cthelper is the userspace library [...]

It's certainly _a_ library for doing certain stuff, but someone can
definitely write another library for doing that as well, so I wouldn't
use ‘the’ here.
M March 19, 2022, 11:29 p.m. UTC | #4
fesoj000 schreef op za 19-03-2022 om 01:47 [+0100]:
> This library is used by conntrack-tools.")

This information is already available with "guix show conntrack-tools".
M March 19, 2022, 11:29 p.m. UTC | #5
fesoj000 schreef op za 19-03-2022 om 01:47 [+0100]:
> With this library, you register, configure, enable and
> +disable user-space helpers

What kind of helpers?
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6dbec31064..8ddd495441 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7298,6 +7298,31 @@  (define-public libnetfilter-cttimeout
                               "libnetfilter_cttimeout/index.html"))
     (license license:gpl2)))
  
+(define-public libnetfilter-cthelper
+  (package
+   (name "libnetfilter_cthelper")
+   (version "1.0.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/"
+                         "libnetfilter_cthelper/files/"
+                         "libnetfilter_cthelper-"
+                         version ".tar.bz2"))
+     (sha256
+      (base32
+       "0gfgzkc1fjniqwk4jxds72c0lcgfhq2591hrvjrvd9nrqiqqwq87"))))
+   (build-system gnu-build-system)
+   (native-inputs (list libmnl pkg-config))
+   (synopsis "Library for kernel user-space helper infrastructure.")
+   (description "libnetfilter_cthelper is the userspace library that provides
+the programming interface to the user-space helper infrastructure available
+since Linux kernel 3.6. With this library, you register, configure, enable and
+disable user-space helpers. This library is used by conntrack-tools.")
+   (home-page (string-append "https://netfilter.org/projects/"
+                             "libnetfilter_cthelper/index.html"))
+   (license license:gpl2)))
+
  (define-public proot
    (package
      (name "proot")