diff mbox series

[bug#54457,9/9] gnu: Add ulogd

Message ID 24cd6dd3-3bc5-d412-3ce8-30cbbd00c57d@gmail.com
State Accepted
Headers show
Series Add netfilter tools and libraries | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

fesoj000 March 19, 2022, 12:47 a.m. UTC
* gnu/packages/linux.scm (ulogd): New variable.
---
  gnu/packages/linux.scm | 44 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 44 insertions(+)

Comments

M March 19, 2022, 1:54 p.m. UTC | #1
fesoj000 schreef op za 19-03-2022 om 01:47 [+0100]:
> +            #t)))))

Trailing #t in phases are not required anymore.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bb8ed6b1fb..5787384431 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7467,6 +7467,50 @@  (define-public libnetfilter-log
     (home-page "https://netfilter.org/projects/libnetfilter_log/index.html")
     (license license:gpl2)))
  
+(define-public ulogd
+  (package
+   (name "ulogd")
+   (version "2.0.7")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/" name "/files/" name
+                         "-" version ".tar.bz2"))
+     (sha256
+      (base32
+       "0ax9959c4bapq78n13bbaibcf1gwjir3ngx8l2dh45lw9m4ha2lr"))))
+   (build-system gnu-build-system)
+   (native-inputs (list pkg-config libnfnetlink libmnl libnetfilter-log
+                        libnetfilter-conntrack libnetfilter-acct))
+   (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+        (add-after 'install 'install-doc
+          (lambda* (#:key outputs #:allow-other-keys)
+            (let ((out-etc (string-append (assoc-ref outputs "out") "/etc"))
+                  (ulogd.conf "ulogd.conf"))
+              (mkdir-p out-etc)
+              (copy-file ulogd.conf (string-append out-etc "/" ulogd.conf)))
+            #t)))))
+   (synopsis "Userspace logging daemon for netfilter/iptables.")
+   (description "ulogd is a userspace logging daemon for netfilter/iptables
+related logging. This includes per-packet logging of security violations,
+per-packet logging for accounting, per-flow logging and flexible user-defined
+accounting.
+@enumerate
+@item
+Packet and flow-based traffic accounting
+@item
+Flexible user-defined traffic accounting via nfacct infrastructure
+@item
+SQL database back-end support: SQLite3, MySQL and PostgreSQL
+@item
+Text-based output formats: CSV, XML, Netfilter's LOG, Netfilter's conntrack
+@end enumerate
+")
+   (home-page "https://netfilter.org/projects/nfacct/index.html")
+   (license license:gpl2)))
+
  (define-public proot
    (package
      (name "proot")