diff mbox series

[bug#54457,8/9] gnu: Add libnetfilter-log

Message ID 7f34743c-4251-6de2-082f-dc9aa3cb2cc9@gmail.com
State Accepted
Headers show
Series Add netfilter tools and libraries | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

fesoj000 March 19, 2022, 12:47 a.m. UTC
* gnu/packages/linux.scm (libnetfilter-log): New variable.
---
  gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
  1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 183f6ef5b4..bb8ed6b1fb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7439,6 +7439,34 @@  (define-public nfacct
     (home-page "https://netfilter.org/projects/nfacct/index.html")
     (license license:gpl2)))
  
+(define-public libnetfilter-log
+  (package
+   (name "libnetfilter_log")
+   (version "1.0.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/" name "/files/" name
+                         "-" version ".tar.bz2"))
+     (sha256
+      (base32
+       "1spy9xs41v76kid5ana8n126f3mvgq6fjibbfbj4kn0larbhix73"))))
+   (build-system gnu-build-system)
+   (native-inputs (list pkg-config libnfnetlink libmnl))
+   (synopsis "Userspace library providing interface to packets logged by
+netfilter.")
+   (description "libnetfilter_log is a userspace library providing interface to
+packets that have been logged by the kernel packet filter. It is is part of a
+system that deprecates the old syslog/dmesg based packet logging. This library
+has been previously known as libnfnetlink_log.
+@enumerate
+@item
+receiving to-be-logged packets from the kernel nfnetlink_log subsystem
+@end enumerate
+")
+   (home-page "https://netfilter.org/projects/libnetfilter_log/index.html")
+   (license license:gpl2)))
+
  (define-public proot
    (package
      (name "proot")