diff mbox series

[bug#52966,2/6] gnu: Add python-pyrss2gen.

Message ID 6e1d0cc95a17fa9e8b8f144b0d4443fe21863c72.1641160577.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#52966,1/6] gnu: Add python-piexif. | expand

Commit Message

Hartmut Goebel Jan. 2, 2022, 10 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyrss2gen): New variable.
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4e408f1d49..4d32b4dd97 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27889,3 +27889,20 @@  keyboard-friendly package.")
 Python.  It includes the tools necessary for extracting, creating,
 manipulating, converting and writing EXIF data to JPEG, WebP and TIFF files.")
     (license license:expat)))
+
+(define-public python-pyrss2gen
+  (package
+    (name "python-pyrss2gen")
+    (version "1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "PyRSS2Gen" version))
+        (sha256
+          (base32 "1rvf5jw9hknqz02rp1vg8abgb1lpa0bc65l7ylmlillqx7bswq3r"))))
+    (build-system python-build-system)
+    (home-page "http://dalkescientific.com/Python/PyRSS2Gen.html")
+    (synopsis "Generate RSS 2.0 feeds using a Python data structure")
+    (description "@code{PyRSS2Gen} is the interface to generate RSS 2.0
+feeds.  PyRSS2Gen builds the feed up by using a XML generator.")
+    (license license:bsd-3)))