diff mbox series

[bug#52966,3/6] gnu: Add python-yapsy.

Message ID 8213b5566b6aa72882fc5c809dd727028b66e343.1641160577.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#52966,1/6] gnu: Add python-piexif. | expand

Commit Message

Hartmut Goebel Jan. 2, 2022, 10 p.m. UTC
* gnu/packages/python-xyz.scm (python-yapsy): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4d32b4dd97..01ae4cf96a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27906,3 +27906,25 @@  manipulating, converting and writing EXIF data to JPEG, WebP and TIFF files.")
     (description "@code{PyRSS2Gen} is the interface to generate RSS 2.0
 feeds.  PyRSS2Gen builds the feed up by using a XML generator.")
     (license license:bsd-3)))
+
+(define-public python-yapsy
+  (package
+    (name "python-yapsy")
+    (version "1.12.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Yapsy" version))
+        (sha256
+          (base32 "12rznbnswfw0w7qfbvmmffr9r317gl1rqg36nijwzsklkjgks4fq"))))
+    (build-system python-build-system)
+    (home-page "http://yapsy.sourceforge.net")
+    (synopsis "Simple plugin system for Python applications")
+    (description "@code{Yapsy}, or Yet Another Plugin SYstem, is a small library
+implementing the core mechanisms needed to build a plugin system into a wider
+application.
+
+The main purpose is to depend only on Python's standard libraries and to
+implement only the basic functionalities needed to detect, load and keep track
+of several plugins.")
+    (license license:bsd-3)))