diff mbox series

[bug#52966,5/6] gnu: Add python-phpserialize.

Message ID 0dbac58656551521c8c0ed23dda7a70bb9bfdeab.1641160577.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#52966,1/6] gnu: Add python-piexif. | expand

Commit Message

Hartmut Goebel Jan. 2, 2022, 10 p.m. UTC
* gnu/packages/python-xyz.scm (python-phpserialize): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5047d05d6c..ede70c5fb9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27962,3 +27962,24 @@  meta-data to:
 @item powerful dependency system
 @end itemize")
     (license license:expat)))
+
+(define-public python-phpserialize
+  (package
+    (name "python-phpserialize")
+    (version "1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "phpserialize" version))
+       (sha256
+        (base32 "19qgkb9z4zjbjxlpwh2w6pxkz2j3iymnydi69jl0jg905lqjsrxz"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      ;; tests missing in pypi archive, anhow they are quite simple and not worth any hassle
+      #:tests? #f))
+    (home-page "http://github.com/mitsuhiko/phpserialize")
+    (synopsis "Python port of the serialize and unserialize functions of PHP")
+    (description
+     "This package provides a port of the serialize and unserialize functions of PHP for Python")
+    (license license:bsd-3)))