diff mbox series

[bug#60429,v2,5/5] gnu: yosys: Update to 0.25.

Message ID 69832a7e061412efc3ef6b0148815534a513b28d.1673202235.git.simon@simonsouth.net
State New
Headers show
Series gnu: yosys: Update to 0.24. | expand

Commit Message

Simon South Jan. 8, 2023, 6:31 p.m. UTC
* gnu/packages/fpga.scm (yosys): Update to 0.25.
[arguments]: Remove obsolete "fix-iverilog-references" phase.
[inputs]: Add zlib.
[propagated-inputs]: Add gtkwave, python, python-click.
---
 gnu/packages/fpga.scm | 35 +++++++++--------------------------
 1 file changed, 9 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 785d385621..45cf0e74cf 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -137,16 +137,15 @@  (define-public iverilog
 (define-public yosys
   (package
     (name "yosys")
-    (version "0.9")
+    (version "0.25")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/YosysHQ/yosys")
-                    (commit (string-append "yosys-" version))
-                    (recursive? #t))) ; for the ‘iverilog’ submodule
+                    (commit (string-append "yosys-" version))))
               (sha256
-                (base32
-                   "0lb9r055h8y1vj2z8gm4ip0v06j5mk7f9zx9gi67kkqb7g4rhjli"))
+               (base32
+                "1j5slm7m02q6n0yv6f3ihv2rgrc4krzcdz6g8v6jmj0gwgh9xi5h"))
               (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
@@ -164,26 +163,6 @@  (define-public yosys
             (lambda _
               (substitute* '("./Makefile")
                 (("ABCEXTERNAL \\?=") "ABCEXTERNAL = abc"))))
-          (add-before 'check 'fix-iverilog-references
-            (lambda* (#:key inputs native-inputs #:allow-other-keys)
-              (let ((iverilog (search-input-file (or native-inputs inputs)
-                                                 "/bin/iverilog")))
-                (substitute* '("./manual/CHAPTER_StateOfTheArt/synth.sh"
-                               "./manual/CHAPTER_StateOfTheArt/validate_tb.sh"
-                               "./techlibs/ice40/tests/test_bram.sh"
-                               "./techlibs/ice40/tests/test_ffs.sh"
-                               "./techlibs/xilinx/tests/bram1.sh"
-                               "./techlibs/xilinx/tests/bram2.sh"
-                               "./tests/bram/run-single.sh"
-                               "./tests/realmath/run-test.sh"
-                               "./tests/simple/run-test.sh"
-                               "./tests/techmap/mem_simple_4x1_runtest.sh"
-                               "./tests/tools/autotest.sh"
-                               "./tests/vloghtb/common.sh")
-                  (("if ! which iverilog") "if ! true")
-                  (("iverilog ") (string-append iverilog " "))
-                  (("iverilog_bin=\".*\"") (string-append "iverilog_bin=\""
-                                                          iverilog "\""))))))
           (add-after 'install 'add-symbolic-link
             (lambda* (#:key inputs #:allow-other-keys)
               ;; Previously this package provided a copy of the "abc"
@@ -203,11 +182,15 @@  (define-public yosys
     (inputs
      (list libffi
            readline
-           tcl))
+           tcl
+           zlib))
     (propagated-inputs
      (list abc
            graphviz ; for dot
+           gtkwave ; for vcd2fst
            psmisc ; for fuser
+           python
+           python-click
            xdot
            z3)) ; should be in path for yosys-smtbmc
     (home-page "https://yosyshq.net/yosys/")