diff mbox series

[bug#64218,6/7] gnu: ldc: Enable building on more architectures.

Message ID 67098e2f87ffdd1bceb29a811680a2ac4d30ed96.1687425321.git.efraim@flashner.co.il
State New
Headers show
Series build ldc with llvm-15 | expand

Commit Message

Efraim Flashner June 22, 2023, 9:19 a.m. UTC
* gnu/packages/dlang.scm (ldc)[arguments]: In the custom phase
'fix-compiler-rt-library-discovery rewrite gnu-triplet->clang-arch to
pass-through unmatched architectures.
---
 gnu/packages/dlang.scm | 19 ++++++-------------
 1 file changed, 6 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 3103e629d9..92600f759e 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -234,19 +234,12 @@  (define-public ldc
                      (system ,(or (%current-target-system)
                                   (%current-system))))
                  (define (gnu-triplet->clang-arch system)
-                   (letrec-syntax
-                       ((matches (syntax-rules (=>)
-                                   ((_ (system-prefix => target) rest ...)
-                                    (if (string-prefix? system-prefix system)
-                                        target
-                                        (matches rest ...)))
-                                   ((_)
-                                    (error "Clang target for system is unknown"
-                                           system)))))
-                     (matches ("x86_64"      => "x86_64")
-                              ("i686"        => "i386")
-                              ("armhf"       => "armhf")
-                              ("aarch64"     => "aarch64"))))
+                   (let ((system-prefix
+                           (car (string-tokenize
+                                  system (char-set-complement (char-set #\-))))))
+                     (cond
+                       ((equal? system-prefix "i686") "i386")
+                       (#t system-prefix))))
                  ;; Coax LLVM into agreeing with Clang about system target
                  ;; naming.
                  (substitute* "driver/linker-gcc.cpp"