mbox series

[bug#64218,0/7] build ldc with llvm-15

Message ID cover.1687425321.git.efraim@flashner.co.il
Headers show
Series build ldc with llvm-15 | expand

Message

Efraim Flashner June 22, 2023, 9:17 a.m. UTC
A series of patches to build ldc with llvm-15. llvm-15 doesn't build on
i686 and I wasn't able to skip the 'make-dynamic-linker-cache phase
without also skipping it on llvm-for-mesa. ldc builds on powerpc64le
with this patch, but still not yet on riscv64.

Efraim Flashner (7):
  gnu: python-lit: Update to 16.0.6.
  gnu: clang-runtime-15: Don't delete static libraries.
  gnu: clang-15: Fix building on i686-linux.
  gnu: lld-15: Adjust max text section size on riscv64-linux.
  gnu: ldc: Build with llvm-15.
  gnu: ldc: Enable building on more architectures.
  gnu: sambamba: Fix building.

 gnu/packages/bioinformatics.scm |  8 +---
 gnu/packages/check.scm          |  6 +--
 gnu/packages/dlang.scm          | 83 ++++++++++++++++++++++-----------
 gnu/packages/llvm.scm           | 45 +++++++++++++-----
 4 files changed, 94 insertions(+), 48 deletions(-)


base-commit: 8b6bc4b2aa579193306cdc7a28f788c9afb4e039

Comments

Efraim Flashner Dec. 3, 2023, 9:21 a.m. UTC | #1
I've applied some of the patches in this series but not the one
upgrading the version of llvm used to build ldc.  I'm still not happy
with the number of tests which need to be skipped to make it pass on
some architectures.

Closing this patch series, feel free to open a new one when adjusting
ldc at at later date.