diff mbox series

[bug#64218,3/7] gnu: clang-15: Fix building on i686-linux.

Message ID 22c1259428c04d43007a291a7bca36f7e1c6ccec.1687425321.git.efraim@flashner.co.il
State New
Headers show
Series build ldc with llvm-15 | expand

Commit Message

Efraim Flashner June 22, 2023, 9:19 a.m. UTC
* gnu/packages/llvm.scm (clang-from-llvm)[arguments]: When building at
least version 15 for i686-linux skip the 'make-dynamic-linker-cache
phase.
---
 gnu/packages/llvm.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 9764552a62..d36a95879a 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -408,7 +408,11 @@  (define* (clang-from-llvm llvm clang-runtime
                             (mkdir-p compl-dir)
                             (rename-file "bash-autocomplete.sh"
                                          (string-append compl-dir "/clang")))))
-                      #t)))))
+                      #t))
+                  ;; GC Warning: Out of Memory! Heap size: 3636 MiB. Returning NULL!
+                  ,@(if (and (version>? version "15") (target-x86-32?))
+                        `((delete 'make-dynamic-linker-cache))
+                        '()))))
 
     ;; Clang supports the same environment variables as GCC.
     (native-search-paths