@@ -1773,13 +1773,13 @@ (define-public qtshadertools
(define-public qtmultimedia
(package
(name "qtmultimedia")
- (version "6.5.2")
+ (version "6.6.2")
(source (origin
(method url-fetch)
(uri (qt-url name version))
(sha256
(base32
- "0xc9k4mlncscxqbp8q46yjd89k4jb8j0ggbi5ad874lycym013wl"))
+ "1v0430jnv97ws6cizn9mi8zr9hcg7rixd0jg7smhdq8apacjb572"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1804,7 +1804,11 @@ (define-public qtmultimedia
;; session bus, which requires an X11 server, and then is still
;; unhappy).
(substitute* "tests/auto/CMakeLists.txt"
- (("add_subdirectory\\(integration)") ""))))
+ (("add_subdirectory\\(integration)") ""))
+ ;; The "qvideoframecolormanagement" tests fail with an
+ ;; 'offscreen rendering' error.
+ (substitute* "tests/auto/unit/multimedia/CMakeLists.txt"
+ (("add_subdirectory\\(qvideoframecolormanagement\\)") ""))))
(add-before 'check 'prepare-for-tests
(lambda _
(setenv "QT_QPA_PLATFORM" "offscreen")))