diff mbox series

[bug#62467,gnome-team,v3,15/15] gnu: Remove lib2geom 1.1.

Message ID 63a739b5f7043911be26be98643cf3be4d94c14f.camel@gmail.com
State New
Headers show
Series Update fundamental packages | expand

Commit Message

Liliana Marie Prikler April 10, 2023, 4:12 p.m. UTC
* gnu/packages/graphics.scm (lib2geom): Update to 1.2.
(lib2geom-1.2): Remove variable.
* gnu/packages/inkscape.scm (inkscape)[inputs]: Use libgeom.
---
 gnu/packages/graphics.scm | 22 ++++------------------
 gnu/packages/inkscape.scm |  2 +-
 2 files changed, 5 insertions(+), 19 deletions(-)

Comments

Maxim Cournoyer April 11, 2023, 8:57 p.m. UTC | #1
Hi Liliana,

The whole series looks good to me (LGTM), although you may want to
cherry-pick my GTK 3 update from core-updates to avoid having to resolve
conflicts down the road.

Feel free to push it to the gnome-team branch (do we have such a branch
yet?).
Liliana Marie Prikler April 12, 2023, 5:33 a.m. UTC | #2
Am Dienstag, dem 11.04.2023 um 16:57 -0400 schrieb Maxim Cournoyer:
> Hi Liliana,
> 
> The whole series looks good to me (LGTM), although you may want to
> cherry-pick my GTK 3 update from core-updates to avoid having to
> resolve conflicts down the road.
IIRC your GTK 3 update requires some changes in Meson that are not
currently in master/gnome-team, right?  Can you tell me which commits I
need to isolate for that?

> Feel free to push it to the gnome-team branch (do we have such a
> branch yet?).
We do, it's currently still tracking master (and I'd like it to stay
that way in case we're done before c-u – even if not, we can rebase it
on the merged master again).

Cheers
Maxim Cournoyer April 13, 2023, 2:33 a.m. UTC | #3
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Dienstag, dem 11.04.2023 um 16:57 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>> 
>> The whole series looks good to me (LGTM), although you may want to
>> cherry-pick my GTK 3 update from core-updates to avoid having to
>> resolve conflicts down the road.
> IIRC your GTK 3 update requires some changes in Meson that are not
> currently in master/gnome-team, right?  Can you tell me which commits I
> need to isolate for that?

Ah, right, it needed at least the change to the meson-build-system in
9bf0a6e4a87c76852c3115476f76056434886181; while you're at it you can
pick 22491ed9c5cc5135db819b80a7ec2ba7dceaa1ee and the meson update to
1.0.1 in 46873adc04ccf2c753362ee14c7faa81fed602c4,
311255adc0d1c3b3aa0f6bed5af58e718f0607b2,
c808cd1bf9c541c1af243bb6bc468ece40b5b05a, and the fixup commit
1887100a2f0bfa99a4670d83587bdc1af5ee1c1c.

Meson 1.1.0 has just been released... it'd be tempting to update it at the
same time since touching meson-build-system entails a full rebuild of
the meson world anyway.

I realize this may be a bit more involved than what you may had been
ready for, and I won't object if you prefer to keep your version,
knowing we'll have to fix some conflicting commit a bit later after
core-updates is merged into master.

Let me know if you hit any issue if you do attempt it, it's still fresh.
Liliana Marie Prikler April 13, 2023, 5:12 a.m. UTC | #4
Am Mittwoch, dem 12.04.2023 um 22:33 -0400 schrieb Maxim Cournoyer:
> Ah, right, it needed at least the change to the meson-build-system in
> 9bf0a6e4a87c76852c3115476f76056434886181; while you're at it you can
> pick 22491ed9c5cc5135db819b80a7ec2ba7dceaa1ee and the meson update to
> 1.0.1 in 46873adc04ccf2c753362ee14c7faa81fed602c4,
> 311255adc0d1c3b3aa0f6bed5af58e718f0607b2,
> c808cd1bf9c541c1af243bb6bc468ece40b5b05a, and the fixup commit
> 1887100a2f0bfa99a4670d83587bdc1af5ee1c1c.
> 
> Meson 1.1.0 has just been released... it'd be tempting to update it
> at the same time since touching meson-build-system entails a full
> rebuild of the meson world anyway.
> 
> I realize this may be a bit more involved than what you may had been
> ready for, and I won't object if you prefer to keep your version,
> knowing we'll have to fix some conflicting commit a bit later after
> core-updates is merged into master.
My personal plan was to bump Meson just before GStreamer, which is the
next big block – thus I'll commit this series as-is and follow up with
the Meson changes afterwards.

I'll first look into bumping Meson to 1.1.0, and if that doesn't work
out apply the commits you mentioned as necessary.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bcc27cc3bf..336f1dd19d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -872,16 +872,16 @@  (define-public ilmbase
 (define-public lib2geom
   (package
     (name "lib2geom")
-    (version "1.1")
+    (version "1.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://gitlab.com/inkscape/lib2geom.git")
+                    (url "https://gitlab.com/inkscape/lib2geom")
                     (commit version)))
-              (file-name (git-file-name name version))
+              (file-name (git-file-name "lib2geom" version))
               (sha256
                (base32
-                "03bx9k1m4bfhmx0ldsg0bks6i8h7fmvl5vbg6gmpq0bk0nkmpnmv"))))
+                "0dq981g894hmvhd6rmfl1w32mksg9hpvpjs1qvfxrnz87rhkknj8"))))
     (build-system cmake-build-system)
     (arguments
      `(#:imported-modules ((guix build python-build-system)
@@ -938,20 +938,6 @@  (define-public lib2geom
     ;; https://gitlab.com/inkscape/inkscape/issues/784).
     (license license:gpl3+)))
 
-(define-public lib2geom-1.2
-  (package
-    (inherit lib2geom)
-    (version "1.2")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://gitlab.com/inkscape/lib2geom")
-                    (commit version)))
-              (file-name (git-file-name "lib2geom" version))
-              (sha256
-               (base32
-                "0dq981g894hmvhd6rmfl1w32mksg9hpvpjs1qvfxrnz87rhkknj8"))))))
-
 (define-public python-booleanoperations
   (package
     (name "python-booleanoperations")
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 7762271299..5c1689fcc7 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -213,7 +213,7 @@  (define-public inkscape/stable
             gtkspell3
             gsl
             poppler
-            lib2geom-1.2
+            lib2geom
             libjpeg-turbo
             libpng
             libxml2