diff mbox series

[bug#62467,gnome-team,2/5] gnu: Make pango-next the new pango.

Message ID 642173f1a695e2c2bef270e178af7dec0c165220.camel@gmail.com
State New
Headers show
Series Update fundamental packages | expand

Commit Message

Liliana Marie Prikler March 26, 2023, 3:53 p.m. UTC
* gnu/packages/gtk.scm (pango): Update to 1.50.4.
(pango-next): Delete variable.
(gtk)[propagated-inputs]: Use pango instead of pango-next.
(pangomm)[propagated-inputs]: Likewise.
(gtksourceview, gtk, pangomm)[inputs]: Use pango instead of pango-next.
* gnu/packages/freedesktop.scm (colord-gtk)[inputs]: Remove pango-next.
* gnu/packages/geo.scm (gnome-maps)[inputs]: Likewise.
* gnu/packages/gnome.scm (evolution-data-server)[inputs]: Likewise.
(network-manager-openvpn)[inputs]: Likewise.
(network-manager-vpnc)[inputs]: Likewise.
(network-manager-openconnect)[inputs]: Likewise.
(network-manager-fortisslvpn)[inputs]: Likewise.
(gnome-bluetooth)[inputs]: Likewise.
(baobab)[inputs]: Likewise.
(gnome-calendar)[inputs]: Likewise.
(gtranslator)[inputs]: Likewise.
* gnu/packages/ibus.scm (ibus)[inputs]: Likewise.
* gnu/packages/messaging.scm (dino)[inputs]: Likewise.
* gnu/packages/webkit.scm (webkitgtk-next)[inputs]: Likewise.
---
 gnu/packages/freedesktop.scm |  4 +---
 gnu/packages/geo.scm         |  1 -
 gnu/packages/gnome.scm       | 25 ++++++-------------------
 gnu/packages/gtk.scm         | 28 +++++-----------------------
 gnu/packages/ibus.scm        |  2 +-
 gnu/packages/messaging.scm   |  1 -
 gnu/packages/webkit.scm      |  3 +--
 7 files changed, 14 insertions(+), 50 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 40edcfdab4..20b2f5a87b 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2113,9 +2113,7 @@  (define-public colord-gtk
            pkg-config
            vala))
     (inputs
-     ;; TODO: remove pango-next after it's the default.
-     (list gtk+
-           pango-next))
+     (list gtk+))
     (propagated-inputs
      ;; colord-gtk.pc refers to all these.
      (list colord gtk))
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 753ab558ad..9465c0eda7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -388,7 +388,6 @@  (define-public gnome-maps
            libshumate
            libsoup
            libxml2
-           pango-next                   ;TODO: remove when it's the default
            rest-next
            webkitgtk))
     (synopsis "Graphical map viewer and wayfinding program")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4a7e188048..90e33d72b6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8399,7 +8399,6 @@  (define-public evolution-data-server
            libphonenumber
            mit-krb5
            openldap
-           pango-next                   ;remove after it's the default
            webkitgtk))
     (synopsis "Store address books and calendars")
     (home-page "https://wiki.gnome.org/Apps/Evolution")
@@ -8707,8 +8706,7 @@  (define-public network-manager-openvpn
            libnma
            libsecret
            network-manager
-           openvpn
-           pango-next))                 ;remove after it's the default
+           openvpn))
     (home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
     (synopsis "OpenVPN plug-in for NetworkManager")
     (description
@@ -8758,8 +8756,7 @@  (define-public network-manager-vpnc
            vpnc
            network-manager
            libnma
-           libsecret
-           pango-next))                 ;TODO: remove after it's the default
+           libsecret))
     (home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
     (synopsis "VPNC plug-in for NetworkManager")
     (description
@@ -8811,8 +8808,7 @@  (define-public network-manager-openconnect
            libxml2
            lz4
            network-manager
-           openconnect
-           pango-next))                 ;TODO: remove after it's the default
+           openconnect))
     (home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
     (synopsis "OpenConnect plug-in for NetworkManager")
     (description
@@ -8875,7 +8871,6 @@  (define-public network-manager-fortisslvpn
                   libsecret
                   network-manager
                   openfortivpn
-                  pango-next ;TODO: remove after it's the default
                   ppp))
     (home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
     (synopsis "Fortinet SSLVPN plug-in for NetworkManager")
@@ -9302,8 +9297,6 @@  (define-public gnome-bluetooth
      (list eudev
            gsound
            libnotify
-           ;; TODO: Delete pango-next after it's the default.
-           pango-next
            python-dbus
            upower))
     (synopsis "GNOME Bluetooth subsystem")
@@ -10016,10 +10009,7 @@  (define-public baobab
            python
            vala))
     (inputs
-     (list gtk libadwaita libhandy
-           ;; XXX: Ensure pango-next is used instead of the equally propagated
-           ;; 'pango'.
-           pango-next))
+     (list gtk libadwaita libhandy))
     (synopsis "Disk usage analyzer for GNOME")
     (description
      "Baobab (Disk Usage Analyzer) is a graphical application to analyse disk
@@ -10617,9 +10607,7 @@  (define-public gnome-calendar
            gsettings-desktop-schemas
            libadwaita
            libdazzle
-           libgweather4-with-libsoup2
-           ;; Remove pango-next when it's the default.
-           pango-next))
+           libgweather4-with-libsoup2))
     (home-page "https://wiki.gnome.org/Apps/Calendar")
     (synopsis "GNOME's calendar application")
     (description
@@ -13458,8 +13446,7 @@  (define-public gtranslator
            gspell
            libgda
            libhandy
-           libsoup
-           pango-next))
+           libsoup))
     (propagated-inputs
      (list gtksourceview-4))              ; required for source view
     (home-page "https://wiki.gnome.org/Apps/Gtranslator")
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 1911ed7774..ee9311ee79 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -427,7 +427,7 @@  (define-public libthai
 (define-public pango
   (package
     (name "pango")
-    (version "1.48.10")
+    (version "1.50.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/pango/"
@@ -436,7 +436,7 @@  (define-public pango
               (patches (search-patches "pango-skip-libthai-test.patch"))
               (sha256
                (base32
-                "166wxhsjb6hb0dk7wkkdcmpvasl9n0a0aa64mdgagzfdidwzbq91"))))
+                "0qn1a7ccs3p5vc6swbqm6hdzka879l0gp9220lq4bcf2gpl67bgl"))))
     (build-system meson-build-system)
     (arguments
      '(#:glib-or-gtk? #t             ; To wrap binaries and/or compile schemas
@@ -481,22 +481,6 @@  (define-public pango
     (home-page "https://pango.gnome.org/")
     (license license:lgpl2.0+)))
 
-;; TODO: Make this the default package in next release cycle.
-(define-public pango-next
-  (package
-    (inherit pango)
-    (name "pango-next")                 ;to avoid profile conflicts
-    (version "1.50.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/pango/"
-                                  (version-major+minor version)
-                                  "/pango-" version ".tar.xz"))
-              (patches (search-patches "pango-skip-libthai-test.patch"))
-              (sha256
-               (base32
-                "0qn1a7ccs3p5vc6swbqm6hdzka879l0gp9220lq4bcf2gpl67bgl"))))))
-
 (define-public pango-1.42
   (package
    (inherit pango)
@@ -713,8 +697,7 @@  (define-public gtksourceview
            glib
            gtk
            libxml2
-           pcre2
-           pango-next))
+           pcre2))
     (home-page "https://wiki.gnome.org/Projects/GtkSourceView")
     (synopsis "GNOME source code widget")
     (description "GtkSourceView is a text widget that extends the standard
@@ -741,7 +724,6 @@  (define-public gtksourceview-4
     (propagated-inputs
      (modify-inputs (package-propagated-inputs gtksourceview)
        (replace "gtk" gtk+)
-       (replace "pango-next" pango)
        (replace "glib" glib)))))
 
 (define-public gtksourceview-3
@@ -1413,7 +1395,7 @@  (define-public gtk
            libxkbcommon
            libxrandr
            libxrender
-           pango-next
+           pango
            vulkan-headers
            vulkan-loader                ;for vulkan graphics API support
            wayland                      ;for wayland display-backend
@@ -1830,7 +1812,7 @@  (define-public pangomm
        ("python" ,python)
        ("xsltproc" ,libxslt)))
     (propagated-inputs
-     (list cairo cairomm glibmm pango-next))
+     (list cairo cairomm glibmm pango))
     (home-page "https://pango.gnome.org//")
     (synopsis "C++ interface to the Pango text rendering library")
     (description
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 7d52c5889e..2bcad54656 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -248,7 +248,7 @@  (define-public ibus
                  ((#:configure-flags flags)
                   #~(cons* "--enable-gtk4" #$flags))))
     (inputs (modify-inputs (package-inputs ibus-minimal)
-              (prepend gtk pango-next)))
+              (prepend gtk)))
     (properties (alist-delete 'hidden? (package-properties ibus-minimal)))))
 
 (define-public ibus-libpinyin
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4b8071e728..66875a2136 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1395,7 +1395,6 @@  (define-public dino
            libsignal-protocol-c
            libsoup
            libsrtp                      ;for calls support
-           pango-next                   ;gtk4 wants pango 1.50+
            qrencode
            sqlite
            webrtc-audio-processing))    ;for A/V support
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 0a51479985..8ef95ce518 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -290,8 +290,7 @@  (define-public webkitgtk-next
        (replace "gtk+" gtk)))
     (inputs
      (modify-inputs (package-inputs webkitgtk)
-       (delete "gtk+-2" "libnotify")
-       (append pango-next)))))          ;TODO: remove after it's the default
+       (delete "gtk+-2" "libnotify")))))
 
 ;;; Required by e.g. emacs-next-pgtk, emacs-xwidgets, and some other GNOME
 ;;; packages for webkit2gtk-4.0.  See also the upstream tracker for libsoup 3: