diff mbox series

[bug#62467,gnome-team,v2,11/12] gnu: librsvg: Fix build.

Message ID 38ca3dfd225bc7f5d1c55bd26b0b4ed4ae3dc460.camel@gmail.com
State New
Headers show
Series Update fundamental packages | expand

Commit Message

Liliana Marie Prikler March 28, 2023, 7:34 p.m. UTC
* gnu/packages/gnome.scm (librsvg)[#:phases]<ignore-failing-tests>: Also
delete SVG files that have been broken by the recent updates.
---
 gnu/packages/gnome.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer April 8, 2023, 7:49 p.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gnome.scm (librsvg)[#:phases]<ignore-failing-tests>: Also
> delete SVG files that have been broken by the recent updates.
> ---
>  gnu/packages/gnome.scm | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 4f47e60505..e43e24dd94 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -3696,7 +3696,12 @@ (define-public librsvg
>                 (("fn multiple_input_files_not_allowed_for_png_output" all)
>                  (string-append "#[ignore] " all))
>                 (("fn stylesheet_option_error" all)
> -                (string-append "#[ignore] " all)))))
> +                (string-append "#[ignore] " all)))
> +             ;; XXX: re-enable when updating this package
> +             (with-directory-excursion "tests/fixtures/reftests/"
> +               (delete-file "filter-component-transfer-from-reference-page.svg")
> +               (delete-file "filter-morphology-from-reference-page.svg")
> +               (delete-file "svg1.1/text-text-03-b.svg"))))

I think a fix for this was contributed to core-updates already; it used
another approach: adjusting the expected value.  We should rebase this
branch on top of core-updates to get it.
Liliana Marie Prikler April 8, 2023, 8:03 p.m. UTC | #2
Am Samstag, dem 08.04.2023 um 15:49 -0400 schrieb Maxim Cournoyer:
> Hi,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/gnome.scm (librsvg)[#:phases]<ignore-failing-tests>:
> > Also
> > delete SVG files that have been broken by the recent updates.
> > ---
> >  gnu/packages/gnome.scm | 7 ++++++-
> >  1 file changed, 6 insertions(+), 1 deletion(-)
> > 
> > diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> > index 4f47e60505..e43e24dd94 100644
> > --- a/gnu/packages/gnome.scm
> > +++ b/gnu/packages/gnome.scm
> > @@ -3696,7 +3696,12 @@ (define-public librsvg
> >                 (("fn
> > multiple_input_files_not_allowed_for_png_output" all)
> >                  (string-append "#[ignore] " all))
> >                 (("fn stylesheet_option_error" all)
> > -                (string-append "#[ignore] " all)))))
> > +                (string-append "#[ignore] " all)))
> > +             ;; XXX: re-enable when updating this package
> > +             (with-directory-excursion "tests/fixtures/reftests/"
> > +               (delete-file "filter-component-transfer-from-
> > reference-page.svg")
> > +               (delete-file "filter-morphology-from-reference-
> > page.svg")
> > +               (delete-file "svg1.1/text-text-03-b.svg"))))
> 
> I think a fix for this was contributed to core-updates already; it
> used another approach: adjusting the expected value.  We should
> rebase this branch on top of core-updates to get it.
I'm not sure how to feel about waiting for core-updates to get through
(especially given that GStreamer, the next big project is on staging,
and the path to getting both merged is still very unclear from my POV).
I did see the core-updates patch, though, and will try cherry-picking
it.

Cheers
Maxim Cournoyer April 9, 2023, 5:07 a.m. UTC | #3
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Samstag, dem 08.04.2023 um 15:49 -0400 schrieb Maxim Cournoyer:
>> Hi,
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> 
>> > * gnu/packages/gnome.scm (librsvg)[#:phases]<ignore-failing-tests>:
>> > Also
>> > delete SVG files that have been broken by the recent updates.
>> > ---
>> >  gnu/packages/gnome.scm | 7 ++++++-
>> >  1 file changed, 6 insertions(+), 1 deletion(-)
>> > 
>> > diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>> > index 4f47e60505..e43e24dd94 100644
>> > --- a/gnu/packages/gnome.scm
>> > +++ b/gnu/packages/gnome.scm
>> > @@ -3696,7 +3696,12 @@ (define-public librsvg
>> >                 (("fn
>> > multiple_input_files_not_allowed_for_png_output" all)
>> >                  (string-append "#[ignore] " all))
>> >                 (("fn stylesheet_option_error" all)
>> > -                (string-append "#[ignore] " all)))))
>> > +                (string-append "#[ignore] " all)))
>> > +             ;; XXX: re-enable when updating this package
>> > +             (with-directory-excursion "tests/fixtures/reftests/"
>> > +               (delete-file "filter-component-transfer-from-
>> > reference-page.svg")
>> > +               (delete-file "filter-morphology-from-reference-
>> > page.svg")
>> > +               (delete-file "svg1.1/text-text-03-b.svg"))))
>> 
>> I think a fix for this was contributed to core-updates already; it
>> used another approach: adjusting the expected value.  We should
>> rebase this branch on top of core-updates to get it.
> I'm not sure how to feel about waiting for core-updates to get through
> (especially given that GStreamer, the next big project is on staging,
> and the path to getting both merged is still very unclear from my POV).
> I did see the core-updates patch, though, and will try cherry-picking
> it.

Staging is at near-merge, if I can get the substitute % a bit higher and
a new python-cryptography in (it fixes a CVE).
Liliana Marie Prikler April 10, 2023, 12:51 p.m. UTC | #4
Am Samstag, dem 08.04.2023 um 15:49 -0400 schrieb Maxim Cournoyer:
> > +             (with-directory-excursion "tests/fixtures/reftests/"
> > +               (delete-file "filter-component-transfer-from-
> > reference-page.svg")
> > +               (delete-file "filter-morphology-from-reference-
> > page.svg")
> > +               (delete-file "svg1.1/text-text-03-b.svg"))))
> 
> I think a fix for this was contributed to core-updates already; it
> used another approach: adjusting the expected value.
Looking at the core-updates patch, it appears to be targeting
tests/fixtures/reftests/bugs/587721-text-transform.svg, not any of the
files referenced above.  Am I missing something?
Maxim Cournoyer April 11, 2023, 1:49 a.m. UTC | #5
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Samstag, dem 08.04.2023 um 15:49 -0400 schrieb Maxim Cournoyer:
>> > +             (with-directory-excursion "tests/fixtures/reftests/"
>> > +               (delete-file "filter-component-transfer-from-
>> > reference-page.svg")
>> > +               (delete-file "filter-morphology-from-reference-
>> > page.svg")
>> > +               (delete-file "svg1.1/text-text-03-b.svg"))))
>> 
>> I think a fix for this was contributed to core-updates already; it
>> used another approach: adjusting the expected value.
> Looking at the core-updates patch, it appears to be targeting
> tests/fixtures/reftests/bugs/587721-text-transform.svg, not any of the
> files referenced above.  Am I missing something?

I see; I guess it was a coincidence but that the issues really are
different?  I didn't look carefully, just thought that two edits fixing
test suite bugs probably were targetting the same one :-).
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4f47e60505..e43e24dd94 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3696,7 +3696,12 @@  (define-public librsvg
                (("fn multiple_input_files_not_allowed_for_png_output" all)
                 (string-append "#[ignore] " all))
                (("fn stylesheet_option_error" all)
-                (string-append "#[ignore] " all)))))
+                (string-append "#[ignore] " all)))
+             ;; XXX: re-enable when updating this package
+             (with-directory-excursion "tests/fixtures/reftests/"
+               (delete-file "filter-component-transfer-from-reference-page.svg")
+               (delete-file "filter-morphology-from-reference-page.svg")
+               (delete-file "svg1.1/text-text-03-b.svg"))))
          (replace 'check
            (lambda* args
              ((assoc-ref gnu:%standard-phases 'check)