diff mbox series

[bug#64378,3/8] gnu: python-uvicorn: Update to 0.22.0.

Message ID 62a86f8c77ff10dc7620e19e0e52ac3248abf599.1688155097.git.peter@polidoro.io
State New
Headers show
Series Add python-platformio plus dependency updates. | expand

Commit Message

Peter Polidoro June 30, 2023, 8:02 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-uvicorn): Update to 0.22.0.
---
 gnu/packages/python-web.scm | 43 ++++++++++---------------------------
 1 file changed, 11 insertions(+), 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2df564f8b7..0c14e14665 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5599,46 +5599,25 @@  (define-public python-httptools
 (define-public python-uvicorn
   (package
     (name "python-uvicorn")
-    (version "0.17.6")
-    (source
-     (origin
-       ;; PyPI tarball has no tests.
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/encode/uvicorn")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0npwls02nhna2lyw2nksxij16l9agf12c9f42pvxb5yrpi9l16c8"))))
-    (build-system python-build-system)
+    (version "0.22.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "uvicorn" version))
+              (sha256
+               (base32
+                "1n4f5i6g4gnsj8z1wvjdyl9admsipc5q6rq5mbcyfz5m7ph7l9vr"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv" "-o" "asyncio_mode=auto"
-                       "-k"
-                       (string-append
-                        ;; These error or fail due to networking.
-                        "not test_keepalive "
-                        "and not test_bind_unix_socket_works_with_"
-                        "reload_or_workers "))))))))
-    (native-inputs
-     (list python-httpx-bootstrap
-           python-pytest
-           python-pytest-asyncio
-           python-pytest-mock
-           python-requests
-           python-trustme
-           python-wsproto))
+     `(#:tests? #f))              ; no tests in PyPI and no setup.py in github
     (propagated-inputs
      (list python-asgiref
            python-click
            python-dotenv
            python-h11
+           python-hatchling
            python-httptools
            python-pyyaml
+           python-typing-extensions
            python-uvloop
            python-watchgod
            python-websockets))