diff mbox series

[bug#64380,6/8] gnu: python-tabulate: Update to 0.9.0.

Message ID 22050952d1e8210db553cdd87231512c65de7107.1688155097.git.peter@polidoro.io
State New
Headers show
Series Add python-platformio plus dependency updates. | expand

Commit Message

Peter Polidoro June 30, 2023, 8:02 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-tabulate): Update to 0.9.0.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++------------
 1 file changed, 10 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c5447a500..829e329158 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18452,19 +18452,17 @@  (define-public python-ply
 (define-public python-tabulate
   (package
     (name "python-tabulate")
-    (version "0.8.9")
+    (version "0.9.0")
     (source (origin
-             (method url-fetch)
-             (uri (pypi-uri "tabulate" version))
-             (sha256
-              (base32
-               "19qkdz8xwk5jxa5xn53mnk76qnh4ysm81vzj664jw1b0azr167gb"))))
-    (build-system python-build-system)
-    (arguments
-     ;; FIXME: The pypi release tarball is missing a 'test/common.py'
-     ;; and the latest release is not tagged in the upstream repository.
-     '(#:tests? #f))
-    (home-page "https://bitbucket.org/astanin/python-tabulate")
+              (method url-fetch)
+              (uri (pypi-uri "tabulate" version))
+              (sha256
+               (base32
+                "0g4b0qnbw55igbpxfxzciqvb6w8ncw4gmcgyq0lyavcnylmv3580"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest
+                         python-setuptools-scm))
+    (home-page "https://github.com/astanin/python-tabulate")
     (synopsis "Pretty-print tabular data")
     (description
      "Tabulate is a library and command-line utility to pretty-print tabular