diff mbox series

[bug#38554,4/5] Add python2-fastentrypoints

Message ID 55a8d50ae479e0036d31ca9ca75aa3ff3796d48d.camel@gmail.com
State Accepted
Headers show
Series Update python-hy to 0.17.0 | expand

Commit Message

Jesse Gibbons Dec. 10, 2019, 2:37 a.m. UTC

Comments

Simon Tournier Dec. 12, 2019, 5:18 p.m. UTC | #1
Hi Jesse,

Thank you for your patches.

As you have maybe seen, I have file a bug [1] to track the Python
packages and the end-of-file of Python 2. Here you add a new Python 2
entry. My question is: do we absolutely need it?

I have seen your bug report about the broken Hy REPL and this series
fixes it. My question is just: can we continue to add
`package-with-python2` packages?


All the best,
simon

[1] https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38420
Jesse Gibbons Dec. 16, 2019, 12:37 a.m. UTC | #2
On Thu, 2019-12-12 at 18:18 +0100, zimoun wrote:
> Hi Jesse,
> 
> Thank you for your patches.
> 
> As you have maybe seen, I have file a bug [1] to track the Python
> packages and the end-of-file of Python 2. Here you add a new Python 2
> entry. My question is: do we absolutely need it?
> 
> I have seen your bug report about the broken Hy REPL and this series
> fixes it. My question is just: can we continue to add
> `package-with-python2` packages?
> 
> 
> All the best,
> simon
> 
> [1] https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38420
This concern is why I added the python2 packages in separate patches
contrary to tradition. I wanted to know what others thought of it. We don't
necessarily need to add the python2 packages, especially when the repository
says this will be the last version of hy to support python2 and those
packages are only added to support hy in python2. I recommend you start a
discussion with Brett, who reviewed the patches and told me to combine patch
1 with 4 and 2 with 5. 
I have too much going on to create and send updated patches before Tuesday,
so I guess now is the time for such discussion.
diff mbox series

Patch

From c93b60f2ea429657a53cc7c018443b1036cdc3fe Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 9 Dec 2019 19:05:17 -0700
Subject: [PATCH 4/5] gnu: Add python2-fastentrypoints

* gnu/packages/python-xyz.scm (python2-fastentrypoints): New variable.
---
 gnu/packages/python-xyz.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6bee2fdd37..9c476b0bce 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16800,6 +16800,9 @@  converters and more, those based on the library itself.")
      "Makes entry_points specified in setup.py load more quickly")
     (license license:bsd-3)))
 
+(define-public python2-fastentrypoints
+  (package-with-python2 python-fastentrypoints))
+
 (define-public python-funcparserlib
   (package
     (name "python-funcparserlib")
-- 
2.24.0