diff mbox series

[bug#38554,1/5] Add python-fastentrypoints

Message ID c4c4868c93becb60a138f981062d4e2fef798285.camel@gmail.com
State Accepted
Headers show
Series Update python-hy to 0.17.0 | expand

Commit Message

Jesse Gibbons Dec. 10, 2019, 2:35 a.m. UTC

diff mbox series

Patch

From 97edcfcbe08031240cc7bae12d588695ff5b81ca Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 9 Dec 2019 18:16:18 -0700
Subject: [PATCH 1/5] gnu: add python-fastentrypoints

* gnu/packages/python-xyz.scm (python-fastentrypoints): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 186e558f2f..7026e65ab6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -67,6 +67,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -16775,3 +16776,25 @@  scratch and manipulate data from Intel HEX file format.  It also includes
 several convenience Python scripts, including \"classic\" hex2bin and bin2hex
 converters and more, those based on the library itself.")
     (license license:bsd-3)))
+
+
+(define-public python-fastentrypoints
+  (package
+    (name "python-fastentrypoints")
+    (version "0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fastentrypoints" version))
+       (sha256
+        (base32
+         "02s1j8i2dzbpbwgq2a3fiqwm3cnmhii2qzc0k42l0rdxd4a4ya7z"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/ninjaaron/fast-entry_points")
+    (synopsis
+     "Makes entry_points specified in setup.py load more quickly")
+    (description
+     "Makes entry_points specified in setup.py load more quickly")
+    (license license:bsd-3)))
+
-- 
2.24.0