diff mbox series

[bug#38554,2/5] Add python-funcparserlib

Message ID c7d10a7adb496b9ea883ac2ccef4e70fccbc3889.camel@gmail.com
State Accepted
Headers show
Series Update python-hy to 0.17.0 | expand

Commit Message

Jesse Gibbons Dec. 10, 2019, 2:36 a.m. UTC

diff mbox series

Patch

From 812077cee02fc4e0f50b69810209b1b40e60dfc0 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 9 Dec 2019 18:31:12 -0700
Subject: [PATCH 2/5] gnu: Add python-funcparserlib

* gnu/packages/python-xyz.scm (python-funcparserlib): New variable.
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7026e65ab6..2161caa2c5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16798,3 +16798,30 @@  converters and more, those based on the library itself.")
      "Makes entry_points specified in setup.py load more quickly")
     (license license:bsd-3)))
 
+(define-public python-funcparserlib
+  (package
+    (name "python-funcparserlib")
+    (version "0.3.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "funcparserlib" version))
+       (sha256
+        (base32
+         "07f9cgjr3h4j2m67fhwapn8fja87vazl58zsj4yppf9y3an2x6dp"))))
+    (native-inputs
+     `(("python-tox" ,python-tox)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "tox"))))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/vlasovskikh/funcparserlib")
+    (synopsis
+     "Recursive descent parsing library based on functional combinators")
+    (description
+     "Recursive descent parsing library based on functional combinators")
+    (license license:expat)))
-- 
2.24.0