diff mbox series

[bug#70390,2/2] gnu: notmuch: Add sfsexp dependency.

Message ID 5460899548ef69b6c0591be8579faa151090834e.1713165432.git.me@fabionatali.com
State New
Headers show
Series Add s-exp support to Notmuch | expand

Commit Message

Fabio Natali April 15, 2024, 7:25 a.m. UTC
sfsexp is a C/C++ library for the manipulation (read, parse, modify, and create)
of symbolic expressions. In an environment where sfsexp is available, Notmuch
will compile with support for a S-expression-based query format. This commit is
to add sfsexp as a Notmuch dependency and therefore to add S-exp support.

Change-Id: Ic3b4a30b2672ad690d66b283e9bdc8e2197f97a7
---
 gnu/packages/mail.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index e0fbd0a5ff..2b5561f706 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -81,6 +81,7 @@  (define-module (gnu packages mail)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages c)
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -1414,6 +1415,7 @@  (define-public notmuch
                   (("/bin/sh") sh))))))))
     (native-inputs
      (list bash-completion
+           git
            pkg-config
            python
            python-docutils
@@ -1427,7 +1429,7 @@  (define-public notmuch
            man-db
            perl))
     (inputs
-     (list glib gmime talloc xapian zlib))
+     (list glib gmime sfsexp talloc xapian zlib))
     (home-page "https://notmuchmail.org/")
     (synopsis "Thread-based email index, search, and tagging")
     (description