diff mbox series

[bug#70390,1/2] gnu: Add sfsexp.

Message ID 139fa7564dab7c3088632370512fcb0d0896da33.1713165432.git.me@fabionatali.com
State New
Headers show
Series Add s-exp support to Notmuch | expand

Commit Message

Fabio Natali April 15, 2024, 7:25 a.m. UTC
* gnu/packages/c.scm (sfsexp): New variable.

Change-Id: Iabfbe10b4ad6134ae886a3d26487f881107b559c
---
 gnu/packages/c.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index c004aade73..ef8f9e473b 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -628,6 +628,28 @@  (define-public packcc
 any other grammar rules.")
     (license license:expat)))
 
+(define-public sfsexp
+  (package
+    (name "sfsexp")
+    (version "1.4.1")
+    (home-page "https://github.com/mjsottile/sfsexp")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03srnpc7p1j7ygd0wx9gybcxhqm50kjzkybh1xs75nwz97q3y2dq"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
+    (synopsis "Symbolic expression library for C and C++")
+    (description
+     "sfsexp is a C/C++ library for the manipulation (read, parse, modify, and create)
+of symbolic expressions.")
+    (license license:lgpl2.1+)))
+
 (define-public sparse
   (package
     (name "sparse")