[bug#75980,rust-team,013/106] gnu: rust-h2-0.1: Change cargo-development-inputs.

Message ID 48386c4cfcc02fbb91a47db7e1ff5e9978a0176d.1738357371.git.herman@rimm.ee
State New
Headers
Series Add cargo-development-inputs. |

Commit Message

Herman Rimm Jan. 31, 2025, 9:09 p.m. UTC
  * gnu/packages/crates-web.scm (rust-h2-0.1): Use rust-webpki-0.18
instead of 0.21.  Remove rust-tokio-rustls-0.12, rust-webpki-roots-0.17.

Change-Id: Ied1aebb5271185423848d03b16fd664788bdcef4
---
 gnu/packages/crates-web.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 22992aabdfe..754f542619d 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -3139,7 +3139,7 @@  (define-public rust-h2-0.1
        (sha256
         (base32 "0qn457y8xh03p7c7cpk76r22gqpyqxc58g5022j3iya7d0j4rcx5"))))
     (arguments
-     `(#:skip-build? #t ;; TODO missing indirect dependency
+     `(#:skip-build? #t ; Missing development dependencies.
        #:cargo-inputs
        (("rust-byteorder" ,rust-byteorder-1)
         ("rust-bytes" ,rust-bytes-0.4)
@@ -3156,14 +3156,14 @@  (define-public rust-h2-0.1
         ("rust-hex" ,rust-hex-0.2)
         ("rust-quickcheck" ,rust-quickcheck-0.4)
         ("rust-rand" ,rust-rand-0.3)
-        ;;("rust-rustls" ,rust-rustls-0.12) requires 0.5
+        ;; ("rust-rustls" ,rust-rustls-0.12)
         ("rust-serde" ,rust-serde-1)
         ("rust-serde-json" ,rust-serde-json-1)
         ("rust-tokio" ,rust-tokio-0.1)
-        ("rust-tokio-rustls" ,rust-tokio-rustls-0.12)
+        ;; ("rust-tokio-rustls" ,rust-tokio-rustls-0.5)
         ("rust-walkdir" ,rust-walkdir-1)
-        ("rust-webpki" ,rust-webpki-0.21)
-        ("rust-webpki-roots" ,rust-webpki-roots-0.17))))))
+        ;; ("rust-webpki-roots" ,rust-webpki-roots-0.14)
+        ("rust-webpki" ,rust-webpki-0.18))))))
 
 (define-public rust-h3-0.0.6
   (package