diff mbox series

[bug#60695,v2,5/9] gnu: nextpnr-ice40: Use gexps.

Message ID 474ea48b61450f18d8518e3c4bbbab13e5efe4af.1674850363.git.simon@simonsouth.net
State New
Headers show
Series gnu: nextpnr-ice40: Update to 0.5. | expand

Commit Message

Simon South Jan. 27, 2023, 8:34 p.m. UTC
* gnu/packages/fpga.scm (nextpnr-ice40)[arguments]: Use gexps.
---
 gnu/packages/fpga.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index bf5ce0e516..b710bce553 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -268,11 +268,12 @@  (define-public nextpnr-ice40
              yosys))
       (build-system cmake-build-system)
       (arguments
-       `(#:configure-flags `("-DARCH=ice40"
-                             ,(string-append "-DICEBOX_ROOT="
-                                             (assoc-ref %build-inputs "icestorm")
-                                             "/share/icebox"))
-         #:tests? #f))
+       (list #:configure-flags
+             #~(list "-DARCH=ice40"
+                     (string-append "-DICEBOX_ROOT="
+                                    #$(this-package-input "icestorm")
+                                    "/share/icebox"))
+             #:tests? #f))
       (synopsis "Place-and-Route tool for FPGAs")
       (description "Nextpnr aims to be a vendor neutral, timing driven,
 FOSS FPGA place and route tool.")