diff mbox series

[bug#63612,2/6] gnu: python-watchdog: Update to 3.0.0.

Message ID 4526a21c0c97d1db4cfaa0b4f175cf7d97a32780.1684600821.git.kiasoc5@disroot.org
State New
Headers show
Series Update searx and dependencies. | expand

Commit Message

kiasoc5 May 20, 2023, 4:44 p.m. UTC
* gnu/packages/python-xyz.scm (python-watchdog): Update to 3.0.0.
[build-system]: Switch to pyproject-build-system.
[arguments]: Delete check phase. Add #:test-flags. Skip more tests.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7e3f6f538..80d5085f3b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26953,24 +26953,23 @@  (define-public python-android-stringslib
 (define-public python-watchdog
   (package
     (name "python-watchdog")
-    (version "2.1.6")
+    (version "3.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "watchdog" version))
        (sha256
-        (base32 "1rx2nyl0cyj0v4ja795cl3gi26577c5wg48syr3byz3ndkgpavm3"))))
-    (build-system python-build-system)
+        (base32 "1y9kk9hbyhidyhpaqg7rg3d3rry26fv8ri4gl72sg9sxb4ha762d"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest" "-k"
-                       ;; This test failed.
-                       "not test_kill_auto_restart")))))))
+     (list
+      #:test-flags
+      '(list "-k"
+             (string-join '("not test_inotify_buffer"
+                            "test_unmount_watched_directory_filesystem"
+                            "test_auto_restart_on_file_change_debounce"
+                            "test_kill_auto_restart")
+                          " and not "))))
     (propagated-inputs
      (list python-pathtools python-pyyaml))
     (native-inputs