diff mbox series

[bug#63612,6/6] gnu: searx: Update to 1.1.0.

Message ID dbf791d67c929222ca260054dbee3e76566d0107.1684600821.git.kiasoc5@disroot.org
State New
Headers show
Series Update searx and dependencies. | expand

Commit Message

kiasoc5 May 20, 2023, 4:44 p.m. UTC
* gnu/packages/search.scm (searx): Update to 1.1.0.
[source](version): append "v" to commit tag.
[build-system]: Use pyproject-build-system.
[arguments](phases): Use G-expression.
[propagated-inputs]: Add python-brotli, python-setproctitle, and python-pysocks.
---
 gnu/packages/search.scm | 42 ++++++++++++++++++++++-------------------
 1 file changed, 23 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 04e03a55b1..947d191858 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -39,6 +39,7 @@  (define-module (gnu packages search)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system meson)
   #:use-module (gnu packages)
   #:use-module (gnu packages adns)
@@ -263,34 +264,35 @@  (define-public tocc
 (define-public searx
   (package
     (name "searx")
-    (version "1.0.0")
+    (version "1.1.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/searx/searx")
-             (commit version)))
+             (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0ghkx8g8jnh8yd46p4mlbjn2zm12nx27v7qflr4c8xhlgi0px0mh"))))
-    (build-system python-build-system)
+        (base32 "070kxivn1nxn3klmnqarr2zldyfpyllpv5cnjdp5kqz19zb20szr"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:tests? #f ;what tests do is make online requests to each engine
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'relax-requirements
-           (lambda _
-             ;; Tests can run after build with 'searx-checker' tool in /bin.
-             ;; allow using a higher dependency version
-             (substitute* "requirements.txt"
-               (("==") ">="))))
-         (add-before 'sanity-check 'set-debug
-           (lambda _
-             ;; the user will need to change the secret key
-             ;; https://github.com/searx/searx/issues/2278
-             (setenv "SEARX_DEBUG" "1"))))))
+     (list #:tests? #f ;what tests do is make online requests to each engine
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'relax-requirements
+                 (lambda _
+                   ;; Tests can run after build with 'searx-checker' tool in /bin.
+                   ;; allow using a higher dependency version
+                   (substitute* "requirements.txt"
+                     (("==") ">="))))
+               (add-before 'sanity-check 'set-debug
+                 (lambda _
+                   ;; the user will need to change the secret key
+                   ;; https://github.com/searx/searx/issues/2278
+                   (setenv "SEARX_DEBUG" "1"))))))
     (propagated-inputs
      (list python-babel
+           python-brotli
            python-certifi
            python-dateutil
            python-flask
@@ -301,7 +303,9 @@  (define-public searx
            python-lxml
            python-pygments
            python-pyyaml
-           python-requests))
+           python-requests
+           python-setproctitle
+           python-pysocks))
     (home-page "https://searx.github.io/searx/")
     (synopsis "Privacy-respecting metasearch engine")
     (description "Searx is a privacy-respecting, hackable metasearch engine.")