diff mbox series

[bug#63612,4/6] gnu: python-werkzeug: Update to 2.2.3.

Message ID 07ca6d2acf1f56fcf0bae35cac3eaec622e916cb.1684600821.git.kiasoc5@disroot.org
State New
Headers show
Series Update searx and dependencies. | expand

Commit Message

kiasoc5 May 20, 2023, 4:44 p.m. UTC
* gnu/packages/python-web.scm (python-werkzeug): Update to 2.2.3.
[build-system]: Switch to pyproject-build-system.
[arguments]: Delete check phase. Use test flags. Skip another test.
[propagated-inputs]: Add python-markupsafe.
[native-inputs]: Add python-cryptography, python-ephemeral-port-reserve,
python-greenlet, and python-watchdog.
---
 gnu/packages/python-web.scm | 29 +++++++++++++++--------------
 1 file changed, 15 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 337c2b72c0..b675edab12 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4625,29 +4625,30 @@  (define-public python-publicsuffix2
 (define-public python-werkzeug
   (package
     (name "python-werkzeug")
-    (version "2.0.2")
+    (version "2.2.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Werkzeug" version))
        (sha256
         (base32
-         "16nvv9dh37ssf5pkny9yj2li0n6wyzsygh8a9i86r3gfipybcaxa"))))
-    (build-system python-build-system)
+         "1zhaznfq2pc6czbg5gjg3pm92hq9mkip9wg6kn5kbnnl2yacq71f"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest"
-                       ;; Test tries to use the network.
-                       "-k not test_reloader_sys_path")))))))
+     (list
+      #:test-flags
+      ;; Test tries to use the network.
+      '(list "-k" "not test_exclude_patterns and not test_reloader_sys_path")))
     (propagated-inputs
-     (list python-requests))
+     (list python-requests python-markupsafe))
     (native-inputs
-     (list python-pytest python-pytest-timeout python-pytest-xprocess))
+     (list python-cryptography
+           python-ephemeral-port-reserve
+           python-greenlet
+           python-pytest
+           python-pytest-timeout
+           python-pytest-xprocess
+           python-watchdog))
     (home-page "https://palletsprojects.com/p/werkzeug/")
     (synopsis "Utilities for WSGI applications")
     (description "One of the most advanced WSGI utility modules.  It includes a