@@ -1702,3 +1702,43 @@ (define-public python-wagtail-factories
(description "This package provides factory boy classes for
@code{wagtail}. It is used for the migrating streamfields.")
(license license:expat)))
+
+(define-public python-wagtail-localize
+ (package
+ (name "python-wagtail-localize")
+ (version "1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wagtail/wagtail-localize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vxd4852wc0qpindxi97nb1sgmdwf60bjc8kd8166p8lhlxgip38"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; TODO Remove this when moving to recent versions of flit-core.
+ (add-after 'unpack 'fix-flit-core-glob
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("wagtail_localize\\/\\*\\*\\/tests")
+ (string-join
+ (find-files "." "tests$" #:directories? #t)
+ "\",\n \"")))))
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (invoke "python" "testmanage.py")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-django python-polib python-wagtail))
+ (native-inputs (list python-dj-database-url
+ python-flit-core
+ python-freezegun
+ python-typing-extensions))
+ (home-page "https://www.wagtail-localize.org")
+ (synopsis "Translating for Wagtail Content Management System (CMS)")
+ (description "This package provides a translation plugin for Wagtail CMS.")
+ (license license:bsd-3)))