diff mbox series

[bug#70158,5/6] gnu: scilab: Improve compilerDetection.sh.

Message ID 20240403062528.5483-5-ngraves@ngraves.fr
State New
Headers show
Series Scilab: Fixup install of local Scilab packages. | expand

Commit Message

Nicolas Graves April 3, 2024, 6:25 a.m. UTC
* gnu/packages/maths.scm (scilab)[source]<origin>: Improve
  compilerDetection.sh error reporting on Guix.
* gnu/packages/patches/scilab-better-compiler-detection.patch :
  Add patch.

Change-Id: Ic055650bc490f8963bf130a126ffbbb51f437811
---
 gnu/packages/maths.scm                        |  1 +
 .../scilab-better-compiler-detection.patch    | 36 +++++++++++++++++++
 2 files changed, 37 insertions(+)
 create mode 100644 gnu/packages/patches/scilab-better-compiler-detection.patch
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9223a86eab..0d530851b1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9718,6 +9718,7 @@  (define-public scilab
        (sha256
         (base32
          "08nyfli3x7gd396ffd1a8zn9fj3gm6a8yw0ggm547c09sp2rgvl7"))
+       (patches (search-patches "scilab-better-compiler-detection.patch"))
        (modules '((guix build utils)
                   (ice-9 ftw)))
        (snippet
diff --git a/gnu/packages/patches/scilab-better-compiler-detection.patch b/gnu/packages/patches/scilab-better-compiler-detection.patch
new file mode 100644
index 0000000000..225f773826
--- /dev/null
+++ b/gnu/packages/patches/scilab-better-compiler-detection.patch
@@ -0,0 +1,36 @@ 
+From fada18edd8905f3321fd1719b1c0a46c66d214af Mon Sep 17 00:00:00 2001
+From: Nicolas Graves <ngraves@ngraves.fr>
+Date: Wed, 27 Mar 2024 06:29:25 +0100
+Subject: [PATCH] scilab: Better debugging in compilerDetection.sh.
+
+---
+ .../dynamic_link/src/scripts/compilerDetection.sh    | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/scilab/modules/dynamic_link/src/scripts/compilerDetection.sh b/scilab/modules/dynamic_link/src/scripts/compilerDetection.sh
+index 0a22a695555..ead86eb58ac 100755
+--- a/scilab/modules/dynamic_link/src/scripts/compilerDetection.sh
++++ b/scilab/modules/dynamic_link/src/scripts/compilerDetection.sh
+@@ -18,10 +18,16 @@ if test -x "$(which gcc 2>/dev/null)"; then
+ fi
+ 
+ # Relaunch configure if files are missing
+-if test ! -s Makefile.orig -o ! -s libtool; then 
++if test ! -s Makefile.orig -o ! -s libtool; then
+     echo "Detection of C/C++/Fortran Compilers"
+     ./configure --disable-static --disable-dependency-tracking "$@"
+-    mv Makefile Makefile.orig
+-else 
++    configure_exit_status=$?
++    if [ $configure_exit_status -ne 0 ]; then
++        cat config.log
++        exit $configure_exit_status
++    else
++        mv Makefile Makefile.orig
++    fi
++else
+     echo "Detection of compilers already done"
+ fi
+-- 
+2.41.0
+