diff mbox series

[bug#70158,3/6] gnu: scilab: Fixup badly-written compilerDetection.sh script.

Message ID 20240403062528.5483-3-ngraves@ngraves.fr
State New
Headers show
Series Scilab: Fixup install of local Scilab packages. | expand

Commit Message

Nicolas Graves April 3, 2024, 6:25 a.m. UTC
* gnu/packages/maths.scm (scilab)
  [arguments]<#:phases>: Fix compilerDetection.sh script in phase
  bootstrap-dynamic_link-scripts.

Change-Id: I7b1c78c4637fa1bc965eca8c516bf0b6cd4b92d1
---
 gnu/packages/maths.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0cb31abf7b..c920bc2f30 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9880,7 +9880,11 @@  (define-public scilab
             (add-after 'bootstrap 'bootstrap-dynamic_link-scripts
               (lambda _
                 (with-directory-excursion "modules/dynamic_link/src/scripts"
-                  ((assoc-ref %standard-phases 'bootstrap)))))
+                  ((assoc-ref %standard-phases 'bootstrap))
+                  (substitute* "compilerDetection.sh"
+                    (("PATHTOCONFIGURE=.*")
+                     "PATHTOCONFIGURE=${BASH_SOURCE[0]%/*}/\n")
+                    (("PROGNAME.*") "\n")))))
             (add-before 'build 'pre-build
               (lambda* (#:key inputs #:allow-other-keys)
                 ;; Fix core.start.