@@ -2006,6 +2006,7 @@ dist_patch_DATA = \
%D%/packages/patches/rust-1.64-fix-riscv64-bootstrap.patch \
%D%/packages/patches/rust-1.70-fix-rustix-build.patch \
%D%/packages/patches/rust-accesskit-winit-unix-only.patch \
+ %D%/packages/patches/rust-arboard-2-unix-only.patch \
%D%/packages/patches/rust-arboard-3-unix-only.patch \
%D%/packages/patches/rust-cargo-edit-remove-ureq.patch \
%D%/packages/patches/rust-ring-0.17-ring-core.patch \
@@ -2162,6 +2162,33 @@ (define-public rust-arboard-3
clipboard.")
(license (list license:expat license:asl2.0))))
+(define-public rust-arboard-2
+ (package
+ (inherit rust-arboard-3)
+ (name "rust-arboard")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "arboard" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1fq8gqbvajjmxdbd65aygf9ramgpvq1bcxj8mxx6vv5ms5a064nw"))
+ (patches (search-patches "rust-arboard-2-unix-only.patch"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; error while interacting with clipboard
+ #:cargo-inputs
+ (("rust-image" ,rust-image-0.23)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-parking-lot" ,rust-parking-lot-0.12)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-wl-clipboard-rs" ,rust-wl-clipboard-rs-0.4)
+ ("rust-x11rb" ,rust-x11rb-0.9))
+ #:cargo-development-inputs
+ (("rust-env-logger" ,rust-env-logger-0.9)
+ ("rust-simple-logger" ,rust-simple-logger-2))))))
+
(define-public rust-arboard-1
(package
(inherit rust-arboard-3)
new file mode 100644
@@ -0,0 +1,53 @@
+diff --git a/Cargo.toml b/Cargo.toml
+index 1d3f38d..7661aad 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -47,11 +47,7 @@ version = "2.1"
+ [features]
+ default = ["image-data"]
+ image-data = [
+- "core-graphics",
+ "image",
+- "winapi/minwindef",
+- "winapi/wingdi",
+- "winapi/winnt",
+ ]
+ wayland-data-control = ["wl-clipboard-rs"]
+
+@@ -73,36 +69,3 @@ optional = true
+
+ [target."cfg(all(unix, not(any(target_os=\"macos\", target_os=\"android\", target_os=\"emscripten\"))))".dependencies.x11rb]
+ version = "0.9"
+-
+-[target."cfg(target_os = \"macos\")".dependencies.core-graphics]
+-version = "0.22"
+-optional = true
+-
+-[target."cfg(target_os = \"macos\")".dependencies.image]
+-version = "0.23"
+-features = ["tiff"]
+-optional = true
+-default-features = false
+-
+-[target."cfg(target_os = \"macos\")".dependencies.objc]
+-version = "0.2"
+-
+-[target."cfg(target_os = \"macos\")".dependencies.objc-foundation]
+-version = "0.1"
+-
+-[target."cfg(target_os = \"macos\")".dependencies.objc_id]
+-version = "0.1"
+-
+-[target."cfg(windows)".dependencies.clipboard-win]
+-version = "4.2"
+-
+-[target."cfg(windows)".dependencies.log]
+-version = "0.4"
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.9"
+-features = [
+- "basetsd",
+- "winuser",
+- "winbase",
+-]