diff mbox series

[bug#69803,rust-team,25/37] gnu: Add rust-color-hex-0.2.

Message ID 20240314211638.6190-25-herman@rimm.ee
State New
Headers show
Series [bug#69803,rust-team,01/37] gnu: Add rust-rename-item-0.1. | expand

Commit Message

Herman Rimm March 14, 2024, 9:16 p.m. UTC
* gnu/packages/crates-io.scm (rust-color-hex-0.2): Add variable.

Change-Id: I09461224f2e3dc77303a2541d2cddaad3299635a
---
 gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c88e535fcc..1cf23d1dd6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12561,6 +12561,26 @@  (define-public rust-color-eyre-0.6
 and well formatted error reports for all kinds of errors.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-color-hex-0.2
+  (package
+    (name "rust-color-hex")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "color-hex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1yacshskcjybr727rh6d38lrfrcdivnd184h49j6qsrj7a8zppzc"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/newcomb-luke/color-hex")
+    (synopsis
+     "Convert hexadecimal strings to an RGBA byte array at compile time")
+    (description
+     "This package provides a procedural macro for converting hexadecimal
+strings to an RGB or RGBA byte array at compile time.")
+    (license license:expat)))
+
 (define-public rust-color-print-0.3
   (package
     (name "rust-color-print")