diff mbox series

[bug#69803,rust-team,30/37] gnu: Add rust-glow-0.13.

Message ID 20240314211638.6190-30-herman@rimm.ee
State New
Headers show
Series [bug#69803,rust-team,01/37] gnu: Add rust-rename-item-0.1. | expand

Commit Message

Herman Rimm March 14, 2024, 9:16 p.m. UTC
* gnu/packages/crates-graphics.scm (rust-glow-0.13): Add variable.
(rust-glow-0.12): Inherit from rust-glow-0.13.

Change-Id: I7292a081947c76fd37939158eb6790c0dc747b02
---
 gnu/packages/crates-graphics.scm | 27 +++++++++++++++++++++------
 1 file changed, 21 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index cb2d6eeeb9..ac1c74b516 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1521,17 +1521,17 @@  (define-public rust-gleam-0.6
      "Generated OpenGL bindings and wrapper for Servo.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-glow-0.12
+(define-public rust-glow-0.13
   (package
     (name "rust-glow")
-    (version "0.12.3")
+    (version "0.13.1")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "glow" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0a1p6c9nff09m4gn0xnnschcpjq35y7c12w69ar8l2mnwj0fa3ya"))))
+        (base32 "1c91n554dp4bdp5d86rpl77ryv6rjyrqn7735m7mfcivqh28wd5x"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-js-sys" ,rust-js-sys-0.3)
@@ -1540,12 +1540,27 @@  (define-public rust-glow-0.12
                        ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
                        ("rust-web-sys" ,rust-web-sys-0.3))))
     (home-page "https://github.com/grovesNL/glow.git")
-    (synopsis "Bindings to run GL anywhere")
+    (synopsis "GL on Whatever: bindings to run Open GL (ES) and WebGL")
     (description
-     "GL on Whatever: a set of bindings to run GL (Open GL, @code{OpenGL} ES, and
-@code{WebGL}) anywhere, and avoid target-specific code.")
+     "GL on Whatever: this package provides a set of bindings to run GL
+(Open GL, @code{OpenGL} ES, and @code{WebGL}) anywhere, and avoid target-
+specific code.")
     (license (list license:expat license:asl2.0 license:zlib))))
 
+(define-public rust-glow-0.12
+  (package
+    (inherit rust-glow-0.13)
+    (name "rust-glow")
+    (version "0.12.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "glow" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0a1p6c9nff09m4gn0xnnschcpjq35y7c12w69ar8l2mnwj0fa3ya"))))))
+
 (define-public rust-glutin-0.31
   (package
     (name "rust-glutin")