diff mbox series

[bug#66180,v2,19/20] gnu: node-path-key: Move package in alphabetical order.

Message ID 20240204124035.994-19-ngraves@ngraves.fr
State New
Headers show
Series [bug#66180,v2,01/20] gnu: node-bindings: Move package in alphabetical order. | expand

Commit Message

Nicolas Graves Feb. 4, 2024, 12:40 p.m. UTC
* gnu/packages/node-xyz.scm (node-path-key): Move package in alphabetical order.

Change-Id: I33d737668063c13f6cd369f8d922eb1aa02f7177
---
 gnu/packages/node-xyz.scm | 52 +++++++++++++++++++--------------------
 1 file changed, 26 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 47c1244674..e6858db1f4 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -827,6 +827,32 @@  (define-public node-oop
 while being as light-weight and simple as possible.")
       (license license:expat))))
 
+(define-public node-path-key
+  (package
+    (name "node-path-key")
+    (version "4.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sindresorhus/path-key")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09f4rf70qhq234fcc3pw9nrqic8cb75pk2b6wfnpr96v0r1h8d8g"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'patch-dependencies 'delete-dependencies
+                    (lambda _
+                      (delete-dependencies '("@types/node" "ava" "tsd" "xo")))))))
+    (home-page "https://github.com/sindresorhus/path-key")
+    (synopsis "Cross-platform utility to compute the PATH environment variable key")
+    (description "@code{path-key} provides an implementation to compute the
+particular cross-platform spellings of the PATH environment variable key.")
+    (license license:expat)))
+
 (define-public node-pbf
   (package
     (name "node-pbf")
@@ -1365,32 +1391,6 @@  (define-public node-wrappy
     (description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
     (license license:isc)))
 
-(define-public node-path-key
-  (package
-    (name "node-path-key")
-    (version "4.0.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/sindresorhus/path-key")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "09f4rf70qhq234fcc3pw9nrqic8cb75pk2b6wfnpr96v0r1h8d8g"))))
-    (build-system node-build-system)
-    (arguments
-     '(#:tests? #f
-       #:phases (modify-phases %standard-phases
-                  (add-after 'patch-dependencies 'delete-dependencies
-                    (lambda _
-                      (delete-dependencies '("@types/node" "ava" "tsd" "xo")))))))
-    (home-page "https://github.com/sindresorhus/path-key")
-    (synopsis "Cross-platform utility to compute the PATH environment variable key")
-    (description "@code{path-key} provides an implementation to compute the
-particular cross-platform spellings of the PATH environment variable key.")
-    (license license:expat)))
-
 (define-public node-serialport-binding-abstract
   (package
     (name "node-serialport-binding-abstract")