diff mbox series

[bug#66180,v2,13/20] gnu: node-file-uri-to-path: Move package in alphabetical order.

Message ID 20240204124035.994-13-ngraves@ngraves.fr
State New
Headers show
Series [bug#66180,v2,01/20] gnu: node-bindings: Move package in alphabetical order. | expand

Commit Message

Nicolas Graves Feb. 4, 2024, 12:40 p.m. UTC
* gnu/packages/node-xyz.scm (node-file-uri-to-path): Move package in alphabetical order.
---
 gnu/packages/node-xyz.scm | 108 +++++++++++++++++++-------------------
 1 file changed, 54 insertions(+), 54 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index dcda27e411..1afbf6deac 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -359,6 +359,60 @@  (define-public node-far
 codes.")
     (license license:expat)))
 
+(define-public node-file-uri-to-path
+  (package
+    (name "node-file-uri-to-path")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/TooTallNate/file-uri-to-path")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "08l779az44czm12xdhgcrnzpqw34s59hbrlfphs7g9y2k26drqav"))))
+    (native-inputs
+     (list esbuild))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies `("@types/mocha"
+                                    "@types/node"
+                                    "@typescript-eslint/eslint-plugin"
+                                    "@typescript-eslint/parser"
+                                    "cpy-cli"
+                                    "eslint"
+                                    "eslint-config-airbnb"
+                                    "eslint-config-prettier"
+                                    "eslint-import-resolver-typescript"
+                                    "eslint-plugin-import"
+                                    "eslint-plugin-jsx-a11y"
+                                    "eslint-plugin-react"
+                                    "mocha"
+                                    "rimraf"
+                                    "typescript"))))
+         (replace 'build
+           (lambda* (#:key inputs native-inputs #:allow-other-keys)
+             (copy-recursively "src" "dist")
+             (invoke (search-input-file (or native-inputs inputs)
+                                        "/bin/esbuild")
+                     "dist/index.ts"
+                     "--outfile=dist/src/index.js"
+                     "--format=cjs"
+                     "--sourcemap"
+                     "--platform=node"))))
+       #:tests? #f))
+    (home-page "https://github.com/TooTallNate/file-uri-to-path")
+    (synopsis "Convert a @code{file:} URI to a file path")
+    (description "This package provides a function to convert a @code{file:}
+URI to a file path.  It accepts a @code{file:} URI and returns a file path
+suitable for use with the @code{fs} module functions.")
+    (license license:expat)))
+
 (define-public node-global-gradle-clean
   (package
     (name "node-global-gradle-clean")
@@ -1229,60 +1283,6 @@  (define-public node-path-key
 particular cross-platform spellings of the PATH environment variable key.")
     (license license:expat)))
 
-(define-public node-file-uri-to-path
-  (package
-    (name "node-file-uri-to-path")
-    (version "2.0.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/TooTallNate/file-uri-to-path")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "08l779az44czm12xdhgcrnzpqw34s59hbrlfphs7g9y2k26drqav"))))
-    (native-inputs
-     (list esbuild))
-    (build-system node-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'patch-dependencies 'delete-dependencies
-           (lambda args
-             (delete-dependencies `("@types/mocha"
-                                    "@types/node"
-                                    "@typescript-eslint/eslint-plugin"
-                                    "@typescript-eslint/parser"
-                                    "cpy-cli"
-                                    "eslint"
-                                    "eslint-config-airbnb"
-                                    "eslint-config-prettier"
-                                    "eslint-import-resolver-typescript"
-                                    "eslint-plugin-import"
-                                    "eslint-plugin-jsx-a11y"
-                                    "eslint-plugin-react"
-                                    "mocha"
-                                    "rimraf"
-                                    "typescript"))))
-         (replace 'build
-           (lambda* (#:key inputs native-inputs #:allow-other-keys)
-             (copy-recursively "src" "dist")
-             (invoke (search-input-file (or native-inputs inputs)
-                                        "/bin/esbuild")
-                     "dist/index.ts"
-                     "--outfile=dist/src/index.js"
-                     "--format=cjs"
-                     "--sourcemap"
-                     "--platform=node"))))
-       #:tests? #f))
-    (home-page "https://github.com/TooTallNate/file-uri-to-path")
-    (synopsis "Convert a @code{file:} URI to a file path")
-    (description "This package provides a function to convert a @code{file:}
-URI to a file path.  It accepts a @code{file:} URI and returns a file path
-suitable for use with the @code{fs} module functions.")
-    (license license:expat)))
-
 (define-public node-segfault-handler
   (package
     (name "node-segfault-handler")