diff mbox series

[bug#66180,v2,01/20] gnu: node-bindings: Move package in alphabetical order.

Message ID 20240204124035.994-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#66180,v2,01/20] gnu: node-bindings: Move package in alphabetical order. | expand

Commit Message

Nicolas Graves Feb. 4, 2024, 12:40 p.m. UTC
* gnu/packages/node-xyz.scm (node-bindings): Move package in alphabetical order.
---
 gnu/packages/node-xyz.scm | 50 +++++++++++++++++++--------------------
 1 file changed, 25 insertions(+), 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index a47c525d14..bb10c885c8 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -107,6 +107,31 @@  (define-public node-acorn
 architecture supporting plugins.")
     (license license:expat)))
 
+(define-public node-bindings
+  (package
+    (name "node-bindings")
+    (version "1.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/TooTallNate/node-bindings")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "100gp6kpjvd4j1dqnp0sbjr1hqx5mz7r61q9qy527jyhk9mj47wk"))))
+    (inputs
+     (list node-file-uri-to-path))
+    (build-system node-build-system)
+    (arguments
+     ;; there are no tests
+     `(#:tests? #f))
+    (home-page "https://github.com/TooTallNate/node-bindings")
+    (synopsis "Locate native addons")
+    (description "This package provides a helper module to locate native
+addons in a wide array of potential locations.")
+    (license license:expat)))
+
 (define-public node-buffer-crc32
   (package
     (name "node-buffer-crc32")
@@ -1258,31 +1283,6 @@  (define-public node-file-uri-to-path
 suitable for use with the @code{fs} module functions.")
     (license license:expat)))
 
-(define-public node-bindings
-  (package
-    (name "node-bindings")
-    (version "1.5.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/TooTallNate/node-bindings")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "100gp6kpjvd4j1dqnp0sbjr1hqx5mz7r61q9qy527jyhk9mj47wk"))))
-    (inputs
-     (list node-file-uri-to-path))
-    (build-system node-build-system)
-    (arguments
-     ;; there are no tests
-     `(#:tests? #f))
-    (home-page "https://github.com/TooTallNate/node-bindings")
-    (synopsis "Locate native addons")
-    (description "This package provides a helper module to locate native
-addons in a wide array of potential locations.")
-    (license license:expat)))
-
 (define-public node-segfault-handler
   (package
     (name "node-segfault-handler")