diff mbox series

[bug#65853,v3,3/8] gnu: scilab: Use gexp for tcl and tk libraries.

Message ID 20231106000354.32423-4-ngraves@ngraves.fr
State New
Headers show
Series Scilab: Big update. | expand

Commit Message

Nicolas Graves Nov. 5, 2023, 11:51 p.m. UTC
* gnu/packages/maths.scm (scilab): Use gexp for tcl and tk libraries.
[argments](configure-flags): Use gexp for tcl and tk libraries.

Change-Id: I31fe9a9e2afd9b6266a2e7a2c7044b3c9d0dfa4f
---
 gnu/packages/maths.scm | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f6d0575979..62c935a868 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9621,6 +9621,8 @@  (define-public scilab
                   tcl
                   tk))
     (arguments
+     (let* ((tcl (this-package-input "tcl"))
+            (tk (this-package-input "tk")))
      (list
       #:configure-flags
       #~(list
@@ -9633,18 +9635,10 @@  (define-public scilab
          "--disable-build-help"
          "--with-external-scirenderer"
          ;; Tcl and Tk library locations.
-         (string-append "--with-tcl-include="
-                        (dirname
-                          (search-input-file %build-inputs "include/tcl.h")))
-         (string-append "--with-tcl-library="
-                        (dirname
-                          (search-input-directory %build-inputs "lib/tcl8")))
-         (string-append "--with-tk-include="
-                        (dirname
-                          (search-input-file %build-inputs "include/tk.h")))
-         (string-append "--with-tk-library="
-                        (dirname
-                          (search-input-directory %build-inputs "lib/tk8.6")))
+         (string-append "--with-tcl-include=" #$tcl "/include")
+         (string-append "--with-tcl-library=" #$tcl "/lib")
+         (string-append "--with-tk-include=" #$tk "/include")
+         (string-append "--with-tk-library=" #$tk "/lib")
          (string-append "--with-eigen-include="
                         (search-input-directory %build-inputs "include/eigen3"))
          ;; Find and link to the OCaml Num package
@@ -9709,7 +9703,7 @@  (define-public scilab
                 (apply invoke "make"
                        "src/cpp/parse/parsescilab.cpp"
                        "src/cpp/parse/scanscilab.cpp"
-                       make-flags)))))))
+                       make-flags))))))))
     (home-page "https://www.scilab.org/")
     (synopsis "Software for engineers and scientists")
     (description "This package provides the non-graphical version of the Scilab