diff mbox series

[bug#65853,v3,1/8] gnu: scilab: Remove uneeded code.

Message ID 20231106000354.32423-2-ngraves@ngraves.fr
State New
Headers show
Series Scilab: Big update. | expand

Commit Message

Nicolas Graves Nov. 5, 2023, 11:51 p.m. UTC
* gnu/packages/maths.scm (scilab):
[source](snippet): Remove directory Visual-Studio-settings and file Scilab.sln.
[arguments](configure-flags):
  Remove uneeded FFLAGS environment variable set.
[arguments](phases):
  prebuild: Remove uneeded SCIHOME setting code.

Change-Id: I71c044e19617bf556bbe95e7ba0cdbd716921055
---
 gnu/packages/maths.scm | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ed1708c77b..88b52eb4fc 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9554,7 +9554,8 @@  (define-public scilab
             (for-each delete-file-recursively
                       '("scilab"
                         "config"
-                        "libs/GetWindowsVersion"))
+                        "libs/GetWindowsVersion"
+                        "Visual-Studio-settings"))
             (for-each delete-file
                       (cons* "aclocal.m4"
                              "configure"
@@ -9566,6 +9567,7 @@  (define-public scilab
                              "m4/ltversion.m4"
                              "m4/lt~obsolete.m4"
                              "m4/pkg.m4"
+                             "Scilab.sln"
                              (find-files "." "^Makefile\\.in$")))
 
             ;; And finally some files in the modules directory:
@@ -9649,10 +9651,7 @@  (define-public scilab
                         (search-input-directory %build-inputs "include/eigen3"))
          ;; Find and link to the OCaml Num package
          "OCAMLC=ocamlfind ocamlc -package num"
-         "OCAMLOPT=ocamlfind ocamlopt -package num -linkpkg"
-         ;; There are some 2018-fortran errors that are ignored
-         ;; with this fortran compiler flag.
-         "FFLAGS=-fallow-argument-mismatch")
+         "OCAMLOPT=ocamlfind ocamlopt -package num -linkpkg")
       #:phases
       #~(modify-phases %standard-phases
           ;; The Num library is specified with the OCAMLC and
@@ -9680,14 +9679,12 @@  (define-public scilab
             (lambda* (#:key inputs #:allow-other-keys)
               ;; Fix scilab script.
               (substitute* "bin/scilab"
-                (("\\/bin\\/ls")
+                (("/bin/ls")
                  (search-input-file inputs "bin/ls")))
               ;; Fix core.start.
               (substitute* "modules/core/etc/core.start"
                 (("'SCI/modules")
-                 "SCI+'/modules"))
-              ;; Set SCIHOME to /tmp before macros compilation.
-              (setenv "SCIHOME" "/tmp")))
+                 "SCI+'/modules"))))
           ;; Prevent race condition
           (add-after 'pre-build 'build-parsers
             (lambda* (#:key (make-flags #~'()) #:allow-other-keys)