diff mbox series

[bug#63619,9/9] gnu: Add python-pymc.

Message ID 20230520231241.962799-9-monego@posteo.net
State New
Headers show
Series Add PyMC. | expand

Commit Message

Vinicius Monego May 20, 2023, 11:12 p.m. UTC
* gnu/packages/statistics.scm (python-pymc): New variable.
---
 gnu/packages/statistics.scm | 40 +++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index c39cf9c0ac..4aac3369ad 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2192,6 +2192,46 @@  (define-public python-arviz
 comparison and diagnostics.")
     (license license:asl2.0)))
 
+(define-public python-pymc
+  (package
+    (name "python-pymc")
+    (version "5.3.1")
+    (source (origin
+              (method git-fetch)        ; no tests in PyPI
+              (uri (git-reference
+                    (url "https://github.com/pymc-devs/pymc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1295b0d1zgnpy2hgm0i9jhnnqgzkya7cwcyhq45fdrz65mi9b65h"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; Tests are computationally intensive and around 130 tests out of ~2800
+     ;; fail due to a missing .cc file in PyTensor.
+     (list #:tests? #f
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'write-permissions
+                          (lambda _
+                            (setenv "HOME" "/tmp"))))))
+    (native-inputs (list python-pytest-cov))
+    (propagated-inputs (list python-arviz
+                             python-cachetools
+                             python-cloudpickle
+                             python-fastprogress
+                             python-numpy
+                             python-pandas
+                             python-pytensor
+                             python-scipy
+                             python-typing-extensions))
+    (home-page "https://github.com/pymc-devs/pymc")
+    (synopsis "Library for probabilistic programming in Python")
+    (description
+     "PyMC (formerly PyMC3) is a Python package for Bayesian
+statistical modeling focusing on advanced Markov chain Monte Carlo (MCMC) and
+variational inference (VI) algorithms.")
+    (license license:asl2.0)))
+
 (define-public python-patsy
   (package
     (name "python-patsy")