mbox series

[bug#63619,0/9] Add PyMC.

Message ID 20230520231058.960514-1-monego@posteo.net
Headers show
Series Add PyMC. | expand

Message

Vinicius Monego May 20, 2023, 11:10 p.m. UTC
This patchset adds the PyMC probabilistic programming package.

Vinicius Monego (9):
  gnu: Add python-vega-datasets.
  gnu: Add python-altair.
  gnu: Add python-einops.
  gnu: python-xarray: Update to 2023.5.0.
  gnu: Add python-xarray-einstats.
  gnu: Add python-arviz.
  gnu: Add python-fastprogress.
  gnu: Add python-pytensor.
  gnu: Add python-pymc.

 gnu/packages/python-science.scm | 150 +++++++++++++++++++++++++++++---
 gnu/packages/python-xyz.scm     |  26 ++++++
 gnu/packages/statistics.scm     | 140 +++++++++++++++++++++++++++++
 3 files changed, 306 insertions(+), 10 deletions(-)

Comments

Ludovic Courtès June 5, 2023, 1:01 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> skribis:

> This patchset adds the PyMC probabilistic programming package.
>
> Vinicius Monego (9):
>   gnu: Add python-vega-datasets.
>   gnu: Add python-altair.
>   gnu: Add python-einops.
>   gnu: python-xarray: Update to 2023.5.0.
>   gnu: Add python-xarray-einstats.
>   gnu: Add python-arviz.
>   gnu: Add python-fastprogress.
>   gnu: Add python-pytensor.
>   gnu: Add python-pymc.

Hi!  From a quick glance it LGTM.

<https://qa.guix.gnu.org/issue/63619> is still lagging behind though.

Ludo’.
Vinicius Monego June 9, 2023, 4:10 a.m. UTC | #2
Em seg, 2023-06-05 às 15:01 +0200, Ludovic Courtès escreveu:

[...]


> Hi!  From a quick glance it LGTM.
> 
> <https://qa.guix.gnu.org/issue/63619> is still lagging behind though.
> 
> Ludo’.

Hi,

I finally understood Versioneer, and fixed the version reporting in
pytensor and pymc. I also updated some of the packages and now pytensor
correctly installs "Faddeeva.h".

My last question would be about the python-vega-datasets package. The
dataset licenses must be "MIT compatible", I'm not sure whether that
implies FSDG compatibility. Some of them do not mention the license:

https://github.com/altair-viz/vega_datasets/blob/master/vega_datasets/dataset_info.json

Developer acknowledges that the provenance of the datasets is difficult
to trace:
https://github.com/altair-viz/vega_datasets/issues/1#issue-288302709

If it's not a problem, then I can push it soon. And I just noticed that
there are tests in this package, they will be enabled before pushing.
Ludovic Courtès June 14, 2023, 9:05 p.m. UTC | #3
Hi,

Vinicius Monego <monego@posteo.net> skribis:

> My last question would be about the python-vega-datasets package. The
> dataset licenses must be "MIT compatible", I'm not sure whether that
> implies FSDG compatibility. Some of them do not mention the license:
>
> https://github.com/altair-viz/vega_datasets/blob/master/vega_datasets/dataset_info.json
>
> Developer acknowledges that the provenance of the datasets is difficult
> to trace:
> https://github.com/altair-viz/vega_datasets/issues/1#issue-288302709
>
> If it's not a problem, then I can push it soon. And I just noticed that
> there are tests in this package, they will be enabled before pushing.

Lack of licensing and provenance information is usually not a good
sign.  What did Debian do, for example?

Note that FSDG is more lax than Debian when it comes to “Non-functional
data”¹.

Thanks,
Ludo’.

¹ https://www.gnu.org/distros/free-system-distribution-guidelines.html
Vinicius Monego June 14, 2023, 10:46 p.m. UTC | #4
Em qua, 2023-06-14 às 23:05 +0200, Ludovic Courtès escreveu:


[...]

> Lack of licensing and provenance information is usually not a good
> sign.  What did Debian do, for example?
> 
> Note that FSDG is more lax than Debian when it comes to “Non-
> functional
> data”¹.
> 
> Thanks,
> Ludo’.
> 
> ¹
> https://www.gnu.org/distros/free-system-distribution-guidelines.html

Debian has a patch to remove the "L.A. Riots" dataset with the
following justification:

> vega_datasets/_data/la-riots.csv is removed since the license is not
> clear and the file is not currently available from Los Angeles Times
> for European users.

So they don't seem to have a problem with the licenses of the other
datasets.

Vinicius
Ludovic Courtès June 21, 2023, 9:48 p.m. UTC | #5
Hi,

Vinicius Monego <monego@posteo.net> skribis:

> Debian has a patch to remove the "L.A. Riots" dataset with the
> following justification:
>
>> vega_datasets/_data/la-riots.csv is removed since the license is not
>> clear and the file is not currently available from Los Angeles Times
>> for European users.
>
> So they don't seem to have a problem with the licenses of the other
> datasets.

OK, good to know.  So I’d say you can keep them, adding links to the
relevant discussions for future reference.

Thanks,
Ludo’.
Vinicius Monego June 25, 2023, 2:01 p.m. UTC | #6
Em qua, 2023-06-21 às 23:48 +0200, Ludovic Courtès escreveu:
> Hi,
> 
> Vinicius Monego <monego@posteo.net> skribis:
> 
> > Debian has a patch to remove the "L.A. Riots" dataset with the
> > following justification:
> > 
> > > vega_datasets/_data/la-riots.csv is removed since the license is
> > > not
> > > clear and the file is not currently available from Los Angeles
> > > Times
> > > for European users.
> > 
> > So they don't seem to have a problem with the licenses of the other
> > datasets.
> 
> OK, good to know.  So I’d say you can keep them, adding links to the
> relevant discussions for future reference.
> 
> Thanks,
> Ludo’.

Thanks for the review. Applied with the patch imported from Debian.

Vinicius