diff mbox series

[bug#63448,2/2] gnu: Add python-mgatk.

Message ID 20230511183412.27180-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#63448,1/2] gnu: Add python-optparse-pretty. | expand

Commit Message

Mădălin Ionel Patrașcu May 11, 2023, 6:34 p.m. UTC
* gnu/packages/bioinformatics.scm (python-mgatk): New variable.
---
 gnu/packages/bioinformatics.scm | 35 +++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Ricardo Wurmus May 12, 2023, 7:37 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioinformatics.scm (python-mgatk): New variable.
> ---> +    (arguments
> +     (list #:tests? #f))   ; There are no tests in the pypi archive.

Can you fetch the sources from https://github.com/caleblareau/mgatk instead?
It is better to make sure this actually works by running at least some
of the tests.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index afca5ab93b..92017b3a07 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12628,6 +12628,41 @@  (define-public python-biothings-client
 API services.")
     (license license:bsd-3)))
 
+(define-public python-mgatk
+  (package
+    (name "python-mgatk")
+    (version "0.6.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mgatk" version))
+       (sha256
+        (base32 "0bxxk3v8lmqcdnm97468p7p3kzb59i5bpgayx7kqzl2p8lfwzi9h"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f))   ; There are no tests in the pypi archive.
+    (propagated-inputs
+     (list python-biopython
+           python-click
+           python-numpy
+           python-optparse-pretty
+           python-pandas
+           python-pysam
+           python-regex
+           python-ruamel.yaml
+           snakemake))
+    (native-inputs
+     (list python-pytest))
+    (home-page "https://github.com/caleblareau/mgatk")
+    (synopsis "Mitochondrial genome analysis toolkit.")
+    (description "This package is a python-based command line interface for
+processing .bam files with mitochondrial reads and generating high-quality
+heteroplasmy estimation from sequencing data.  The mgatk package places a
+special emphasis on mitochondrial genotypes generated from single-cell genomics
+data, primarily @acronym{mtscATAC-seq, mitochondrial single-cell ATAC-sequence},
+but is generally applicable across other assays.")
+    (license license:expat)))
+
 (define-public python-multivelo
   (package
     (name "python-multivelo")