diff mbox series

[bug#63448,1/2] gnu: Add python-optparse-pretty.

Message ID 20230511183412.27180-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#63448,1/2] gnu: Add python-optparse-pretty. | expand

Commit Message

Mădălin Ionel Patrașcu May 11, 2023, 6:34 p.m. UTC
* gnu/packages/python-xyz.scm (python-optparse-pretty): New variable
---
 gnu/packages/python-xyz.scm | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)


base-commit: e2eb43f945fd467e9b55a4b3c91cd186cf32e268

Comments

Ricardo Wurmus May 12, 2023, 7:39 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/python-xyz.scm (python-optparse-pretty): New variable> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "optparse-pretty" version))
> +       (sha256
> +        (base32 "1920wbh2b7a8qn7zx2iiqbcdaax335l81a73x9pp8h11yzs2jdmh"))))
> +    (build-system pyproject-build-system)
> +    (arguments
> +     (list #:tests? #f))   ; There are no tests in the pypi archive.

There are no tests at all, not just in pypi.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4f48d80eb6..9fabfce79f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -66,7 +66,7 @@ 
 ;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2019, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2019, 2021-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2020 Riku Viitanen <riku.viitanen@protonmail.com>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
@@ -2690,6 +2690,27 @@  (define-public python-diskcache
     (description "DiskCache is a disk and file backed persistent cache.")
     (license license:asl2.0)))
 
+(define-public python-optparse-pretty
+  (package
+    (name "python-optparse-pretty")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "optparse-pretty" version))
+       (sha256
+        (base32 "1920wbh2b7a8qn7zx2iiqbcdaax335l81a73x9pp8h11yzs2jdmh"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f))   ; There are no tests in the pypi archive.
+    (home-page "https://github.com/gvalkov/optparse-pretty")
+    (synopsis "Compact help formatter for optparse")
+    (description
+     "This module provides two help formatters for optparse.  They provide
+terser and more customizable option formatting in comparison to the default
+help formatter.")
+    (license license:bsd-3)))
+
 (define-public python-orjson
   (package
     (name "python-orjson")