diff mbox series

[bug#63176,08/10] gnu: python-pytest-remotedata: Update to 0.4.0.

Message ID 20230429170840.105227-8-felgru@posteo.net
State New
Headers show
Series Fix some broken python packages. | expand

Commit Message

Felix Gruber April 29, 2023, 5:08 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-remotedata): Update to 0.4.0.
[build-system]: Use pyproject-build-system.
[arguments]: Use #:test-flags instead of custom 'check phase.
[propagated-inputs]: Remove python-six.
---
 gnu/packages/python-check.scm | 26 ++++++++++----------------
 1 file changed, 10 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 10731178e3..160d30179b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -754,30 +754,24 @@  (define-public python-pytest-openfiles
 (define-public python-pytest-remotedata
   (package
     (name "python-pytest-remotedata")
-    (version "0.3.2")
+    (version "0.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-remotedata" version))
        (sha256
-        (base32 "1h6g6shib6z07azf12rnsa053470ggbd7hy3bnbw8nf3nza5h372"))))
-    (build-system python-build-system)
+        (base32 "1j5106j331cfdyfcwzrbs3yby84mq1b0kddfysq12z2dwdcca8dy"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Make the installed plugin discoverable by Pytest.
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-vv" "-k"
-                     (string-append
-                      ;; These tests require internet access. Disable them.
-                      "not test_default_behavior"
-                      " and not test_strict_with_decorator")))))))
+     (list
+      #:test-flags
+      '(list "-k"
+             (string-append
+               ;; These tests require internet access. Disable them.
+               "not test_default_behavior"
+               " and not test_strict_with_decorator"))))
     (native-inputs
      (list python-pytest))
-    (propagated-inputs
-     (list python-six))
     (home-page "https://github.com/astropy/pytest-remotedata")
     (synopsis "Pytest plugin for controlling remote data access")
     (description