diff mbox series

[bug#63176,06/10] gnu: python-pytest-doctestplus: Update to 0.12.1.

Message ID 20230429170840.105227-6-felgru@posteo.net
State New
Headers show
Series Fix some broken python packages. | expand

Commit Message

Felix Gruber April 29, 2023, 5:08 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-doctestplus): Update to 0.12.1.
  [build-system]: Use pyproject-build-system.
  [arguments]: Use #:test-flags instead of custom 'check phase.
---
 gnu/packages/python-check.scm | 33 ++++++++++++++-------------------
 1 file changed, 14 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index c42cd426b1..f451a5e999 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -14,7 +14,7 @@ 
 ;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
-;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022, 2023 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
@@ -577,30 +577,25 @@  (define-public python-pytest-arraydiff
 (define-public python-pytest-doctestplus
   (package
     (name "python-pytest-doctestplus")
-    (version "0.11.2")
+    (version "0.12.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest-doctestplus" version))
        (sha256
-        (base32 "0j1lvlj3ps975q9hmg8i6rpqm0313j3r18bc3l8mz6khb7vav4zk"))))
-    (build-system python-build-system)
+        (base32 "10ciqylgziihxwxryxvxgmkqgws51pqcarn0gbh1d4cxx55rx5vs"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             ;; Make the installed plugin discoverable by Pytest.
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest" "-k"
-                       (string-append   ; skip tests that require remote data
-                        "not test_remote_data_url"
-                        " and not test_remote_data_float_cmp"
-                        " and not test_remote_data_ignore_whitespace"
-                        " and not test_remote_data_ellipsis"
-                        " and not test_remote_data_requires"
-                        " and not test_remote_data_ignore_warnings"))))))))
+     (list
+      #:test-flags
+      '(list "-k"
+             (string-append   ; skip tests that require remote data
+               "not test_remote_data_url"
+               " and not test_remote_data_float_cmp"
+               " and not test_remote_data_ignore_whitespace"
+               " and not test_remote_data_ellipsis"
+               " and not test_remote_data_requires"
+               " and not test_remote_data_ignore_warnings"))))
     (native-inputs
      (list python-pytest python-setuptools-scm))
     (home-page "https://github.com/astropy/pytest-doctestplus")