diff mbox series

[bug#63176,03/10] gnu: Add texlive-alphalph.

Message ID 20230429170840.105227-3-felgru@posteo.net
State New
Headers show
Series Fix some broken python packages. | expand

Commit Message

Felix Gruber April 29, 2023, 5:08 p.m. UTC
* gnu/packages/tex.scm (texlive-alphalph): New variable.
---
 gnu/packages/tex.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou April 29, 2023, 7:22 p.m. UTC | #1
Hello,

Felix Gruber <felgru@posteo.net> writes:

> * gnu/packages/tex.scm (texlive-alphalph): New variable.

Thanks. I will not comment about other patches in this set, but I will
do about this one.

> +(define-public texlive-alphalph
> +  (package
> +    (inherit (simple-texlive-package
> +               "texlive-alphalph"
> +               (list "doc/latex/alphalph/"
> +                     "source/latex/alphalph/"
> +                     "tex/generic/alphalph/")
> +               (base32 "0ap59hmg0brg2wlh3bl77jxfxrk7hphhdal8cr05mby9bw35gffy")
> +               #:trivial? #t))

This is not a "trivial" package. It contains a ".dtx" file, that you
need to run in order to generate the runfiles.

As a rule of thumb, if the importer, which I assume you used, doesn't
set #:trivial keyword, you shouldn't either.

> +    (build-system texlive-build-system)
> +    (home-page "https://ctan.org/pkg/alphalph")
> +    (synopsis "Convert numbers to letters")
> +    (description "This package provides commands \\alphalph and
> +\\AlphAlph.  They are like \\number but the expansion consists of
> +lowercase and uppercase letters respectively (1 to a, 26 to z, 27 to
> +aa, 52 to zz, 53 to ba, 702 to zz, 703 to aaa, etc.).  Can be used as a
> +replacement for LaTeX's \\@@alph and \\@@Alph macros.")

I suggest to use @code{...} around LaTeX commands. Also, the last
sentence in not complete.

Regards,
Nicolas Goaziou April 29, 2023, 7:59 p.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Felix Gruber <felgru@posteo.net> writes:
>
>> * gnu/packages/tex.scm (texlive-alphalph): New variable.
>
> Thanks. I will not comment about other patches in this set, but I will
> do about this one.

Completing myself:

This Texlive package also requires texlive-intcalc and texlive-infwarerr
as propagated inputs.
Felix Gruber April 30, 2023, 9:07 p.m. UTC | #3
Hi Nicolas,

thank you for your review.
This was the first time that I've created a texlive package, so your 
comments were quite helpful to better understand how to properly define 
such a package.

I'll shortly submit an updated patch for texlive-alphalph. It would be 
great if you could take another look to see if I got it right this time 
or if there is still something that I should change.

Kind regards,
Felix
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a2f1de4e35..b75f4aeaa7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
+;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12067,6 +12068,25 @@  (define-public texlive-kastrup
 LaTeX and plain TeX.")
     (license (license:fsf-free "file:/binhex.dtx"))))
 
+(define-public texlive-alphalph
+  (package
+    (inherit (simple-texlive-package
+               "texlive-alphalph"
+               (list "doc/latex/alphalph/"
+                     "source/latex/alphalph/"
+                     "tex/generic/alphalph/")
+               (base32 "0ap59hmg0brg2wlh3bl77jxfxrk7hphhdal8cr05mby9bw35gffy")
+               #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/alphalph")
+    (synopsis "Convert numbers to letters")
+    (description "This package provides commands \\alphalph and
+\\AlphAlph.  They are like \\number but the expansion consists of
+lowercase and uppercase letters respectively (1 to a, 26 to z, 27 to
+aa, 52 to zz, 53 to ba, 702 to zz, 703 to aaa, etc.).  Can be used as a
+replacement for LaTeX's \\@@alph and \\@@Alph macros.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-latex-translations
   (package
     (inherit (simple-texlive-package