diff mbox series

[bug#63017,06/24] gnu: Add go-github-com-jcmturner-gofork.

Message ID 20230422162750.17012-6-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 22, 2023, 4:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-jcmturner-gofork): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4ddd499e43..f00c18897e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1458,6 +1458,29 @@  (define-public go-github-com-jcmturner-dnsutils-v2
 network applications that require accessing services using SRV records.")
     (license license:asl2.0)))
 
+(define-public go-github-com-jcmturner-gofork
+  (package
+    (name "go-github-com-jcmturner-gofork")
+    (version "1.7.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jcmturner/gofork")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0w1j6b671121r6md5w7hnh2d0sa332pw5q49yihw23wdfinknyin"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/jcmturner/gofork"))
+    (home-page "https://github.com/jcmturner/gofork")
+    (synopsis "Modified Go standard library packages")
+    (description
+     "This repository contains modified Go standard library packages for use as work
+arounds until issues are addressed in the official distribution.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-kataras-golog
   (package
     (name "go-github-com-kataras-golog")