diff mbox series

[bug#63017,17/24] gnu: Add go-github-com-leonelquinteros-gotext.

Message ID 20230422162750.17012-17-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 22, 2023, 4:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-leonelquinteros-gotext): New variable.
---
 gnu/packages/golang.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1dce82e49c..79d20abd2a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1667,6 +1667,42 @@  (define-public go-github-com-kortschak-utter
 aid data snapshotting.")
     (license license:isc)))
 
+(define-public go-github-com-leonelquinteros-gotext
+  (package
+    (name "go-github-com-leonelquinteros-gotext")
+    (version "1.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/leonelquinteros/gotext")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15zjc7s1p29izagc84andzhnxw17763rax31jqvf9r5fzvlm0ccn"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/leonelquinteros/gotext"))
+    (propagated-inputs (list go-golang-org-x-tools go-golang-org-x-text))
+    (home-page "https://github.com/leonelquinteros/gotext")
+    (synopsis "GNU gettext utilities in Go")
+    (description "This package implements GNU gettext utilities in Go.  It features:
+@itemize
+@item Implements GNU gettext support in native Go.
+@item Complete support for PO files including:
+@item Support for MO files.
+@item Thread-safe: This package is safe for concurrent use across multiple
+goroutines.
+@item It works with UTF-8 encoding as it's the default for Go language.
+@item Unit tests available.
+@item Language codes are automatically simplified from the form en_UK to en if
+the first isn't available.
+@item Ready to use inside Go templates.
+@item Objects are serializable to []byte to store them in cache.
+@item Support for Go Modules.
+@end itemize")
+    (license license:expat)))
+
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")