diff mbox series

[bug#63017,09/24] gnu: Add go-github-com-jcmturner-rpc.

Message ID 20230422162750.17012-9-ngraves@ngraves.fr
State New
Headers show
Series [bug#63017,01/24] gnu: Add go-github-com-git-lfs-gitobj-v2. | expand

Commit Message

Nicolas Graves April 22, 2023, 4:27 p.m. UTC
* gnu/packages/golang.scm (go-github-com-jcmturner-rpc): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 66bb95fe7f..9738e1ec99 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1505,6 +1505,33 @@  (define-public go-github-com-jcmturner-gofork
 arounds until issues are addressed in the official distribution.")
     (license license:bsd-3)))
 
+(define-public go-github-com-jcmturner-rpc
+  (package
+    (name "go-github-com-jcmturner-rpc")
+    (version "2.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jcmturner/rpc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1nm4j2nwcszghldw39rwdx2hr56i1lybfpv33y4gd67w6qcqbpsi"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/jcmturner/rpc"))
+    (propagated-inputs
+     (list go-golang-org-x-net go-github-com-stretchr-testify))
+    (home-page "https://github.com/jcmturner/rpc")
+    (synopsis "Remote Procedure Call libraries")
+    (description
+     "This package provides a partial Go implementation of the Remote Call
+Procedure libraries, presented in
+@@url{http://pubs.opengroup.org/onlinepubs/9629399/,CDE 1.1: Remote Procedure
+Call}.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-kataras-golog
   (package
     (name "go-github-com-kataras-golog")