diff mbox series

[bug#61838,v2,03/13] gnu: Add r-n2r.

Message ID 20230227233716.2455-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61838,v2,01/13] gnu: Add r-simplermarkdown. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 27, 2023, 11:37 p.m. UTC
* gnu/packages/cran.scm (r-n2r): New variable.

Changes from v1:
- [description]: Changed the description after the Ricardo's observation.
I hope that this is solve the issue.

---
 gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 4db367f8ae4e704784ced52b552437ca00b94b89
prerequisite-patch-id: edae0018d5bb597484681580e87ff4e84d3e4f97
prerequisite-patch-id: fe2fd38a8a277bb9352431960ff6322e66f56895
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f5dc9c3980..29f11bf3de 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8334,6 +8334,32 @@  (define-public r-tinytest
 ")
     (license license:gpl3)))
 
+(define-public r-n2r
+  (package
+    (name "r-n2r")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "N2R" version))
+       (sha256
+        (base32 "12bv7xx6j6222qgpv6g61i68017fz0x6fjg9a9k5yhgw3zk05hpk"))))
+    (properties `((upstream-name . "N2R")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-matrix
+           r-rcpp
+           r-rcppeigen
+           r-rcppspdlog))
+    (home-page "https://github.com/kharchenkolab/N2R")
+    (synopsis "Fast and scalable approximate k-Nearest Neighbor search methods")
+    (description
+     "This package implements methods to perform fast approximate K-nearest neighbor
+search on the input matrix.  The algorithm is based on the N2 implementation of an
+approximate nearest neighbor search using hierarchical @acronym{NSW, Navigable Small
+World} graphs.")
+    (license license:asl2.0)))
+
 (define-public r-network
   (package
     (name "r-network")