diff mbox series

[bug#61838,v2,02/13] gnu: Add r-rcppspdlog.

Message ID 20230227211744.1978-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61838,v2,01/13] gnu: Add r-simplermarkdown. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 27, 2023, 9:17 p.m. UTC
* gnu/packages/cran.scm (r-rcppspdlog): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Changes since v1:
- [synopsis]: removed single quotes.


base-commit: 4db367f8ae4e704784ced52b552437ca00b94b89
prerequisite-patch-id: edae0018d5bb597484681580e87ff4e84d3e4f97
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 965b10c3a5..f5dc9c3980 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4992,6 +4992,30 @@  (define-public r-rcppml
 factorization and divisive clustering for large sparse and dense matrices.")
     (license license:gpl2+)))
 
+(define-public r-rcppspdlog
+  (package
+    (name "r-rcppspdlog")
+    (version "0.0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RcppSpdlog" version))
+       (sha256
+        (base32 "1nan0hm49xdl2l1lskm1jf01clfh7aw2v6h57j35qysvg8219fcx"))))
+    (properties `((upstream-name . "RcppSpdlog")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (native-inputs (list r-simplermarkdown))
+    (home-page "https://github.com/eddelbuettel/rcppspdlog")
+    (synopsis "R and C++ interfaces to spdlog C++ header library for logging")
+    (description
+     "The spdlog library is a widely-used and very capable header-only C++ library
+for logging.  This package includes its headers as an R package to permit other R
+packages to deploy it via a simple @code{LinkingTo: RcppSpdlog}.  As of version
+0.0.9, it also provides both simple R logging functions and compiled functions
+callable by other packages.")
+    (license license:gpl2+)))
+
 (define-public r-rcppthread
   (package
     (name "r-rcppthread")