diff mbox series

[bug#61252,3/3] gnu: Add r-dorothea.

Message ID 20230203121854.95308-3-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61250,1/3] gnu: Add r-viper. | expand

Commit Message

nafkhamdc Feb. 3, 2023, 12:18 p.m. UTC
* gnu/packages/bioconductor.scm (r-dorothea): New variable.
---
 gnu/packages/bioconductor.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ricardo Wurmus Feb. 3, 2023, 3:49 p.m. UTC | #1
Thanks for the patch!

Since this depends on r-viper, which is nonfree I cannot add this
package to Guix.  I have instead pushed it to the channel
“guix-science-nonfree”.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 521d6c00be..0786160b5e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -466,6 +466,31 @@  (define-public r-bsgenome-mmusculus-ucsc-mm10
 in Biostrings objects.")
     (license license:artistic2.0)))
 
+(define-public r-dorothea
+  (package
+    (name "r-dorothea")
+    (version "1.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "dorothea" version
+                                     'experiment))
+              (sha256
+               (base32
+                "05vkb5mash2m8p6njk842sy5pz7vblrm8n9bphqbslm86kld5n92"))))
+    (properties `((upstream-name . "dorothea")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bcellviper r-dplyr r-magrittr r-viper))
+    (native-inputs (list r-knitr))
+    (home-page "https://saezlab.github.io/dorothea/")
+    (synopsis "Collection of human and mouse TF regulons")
+    (description
+     "DoRothEA is a gene regulatory network containing signed transcription factor.
+DoRothEA regulons, the collection of a TF andits transcriptional targets,
+were curated and collected from different types ofevidence for both human
+and mouse.  A confidence level was assigned to each TF-target interaction
+based on the number of supporting evidence.")
+    (license license:gpl3)))
+
 (define-public r-genomeinfodbdata
   (package
     (name "r-genomeinfodbdata")